Download

Error with Audio Capture Component

Hello,

Whenever I add an audio capture component, and assign the same sub mix to a Niagara Script, I receive the below error message.

What is particularly interesting to me, is everything is installed at either E:\Epic Games\UE_5.0EA or the project is located at E:\Unreal Projects\InfiniteMatrixStarter 5.0 and the project is being built in E:\Unreal Projects\InfiniteMatrixStarter 5.0\Build

I found this error thread: Please help me Unable to package after updating Bridge

Which suggests that Quixel Bridge is the culprit… As I’m not currently using it, I see no reason not to disable it. But I still receive the same error.

This runs fine in the UE IDE when I press the play button.

I also found this error thread: UE5 fails to initialize. Assertion failed: IsValid() [File:D:/build/++UE5/Sync/Engine/Source/Runtime/Core/Private/Windows/WindowsPlatformFile.cpp] [Line: 602]

And have tried uninstalling and reinstalling UE multiple times.

Final interesting(?) note, when I build the same exact blueprint in UE4, it works in the IDE just fine, but when compiled to an .exe the Niagara systems stop reacting to the audio. Though I don’t receive an error message.

Thanks!
Q

Assertion failed: IsInGameThread() [File:D:/build/++UE5/Sync/Engine/Source/Runtime/Engine/Private/AudioThread.cpp] [Line: 245] 



0x00007ff782f3bc27 InfiniteMatrix.exe!UnknownFunction []
0x00007ff782f27c62 InfiniteMatrix.exe!UnknownFunction []
0x00007ff77e901ab1 InfiniteMatrix.exe!UnknownFunction []
0x00007ff782ef6d30 InfiniteMatrix.exe!UnknownFunction []
0x00007ff77e8f77a8 InfiniteMatrix.exe!UnknownFunction []
0x00007ff77e8fe89f InfiniteMatrix.exe!UnknownFunction []
0x00007ff77fa743f9 InfiniteMatrix.exe!UnknownFunction []
0x00007ff77fa57adc InfiniteMatrix.exe!UnknownFunction []
0x00007ff77fa7f229 InfiniteMatrix.exe!UnknownFunction []
0x00007ff77f71f206 InfiniteMatrix.exe!UnknownFunction []
0x00007ff77f72a973 InfiniteMatrix.exe!UnknownFunction []
0x00007ff77f72e63b InfiniteMatrix.exe!UnknownFunction []
0x00007ff77f745bbb InfiniteMatrix.exe!UnknownFunction []
0x00007ff77f76222c InfiniteMatrix.exe!UnknownFunction []
0x00007ff77f648cfb InfiniteMatrix.exe!UnknownFunction []
0x00007ff77f6411c0 InfiniteMatrix.exe!UnknownFunction []
0x00007fffa0d27034 KERNEL32.DLL!UnknownFunction []
0x00007fffa29a2651 ntdll.dll!UnknownFunction []

Crash in runnable thread FAsyncLoadingThread

Interestingly, if I select “Package for Distribution” it does compile… though I run into other issues.