Dynamic Shadow Quality And Fading Out?

My scene is lit by a directional light and casts dynamic shadows, its a cel shaded game so these shadows are supposed to be sharp

My problem is that at a distance the shadows become very choppy and also fade out from a very short distance how do I fix this?

Here are some pictures for reference.

From a distance:


Up close and how I’d like it to look all the time:


Also if there is a better method to achieving these sharp shadows/lighting please let me know, any help is appreciated thank you!

I’m assuming you’re using a stationary directional light with cascades?

When you’re close to stuff the system shows you dynamic shadows, when you reach the cascade distance set in the directional light details, it switches to the static shadow.

Two ways to make it look better:

  1. Increase the cascade distance in the directional light

  2. Increase the lightmap resolution on the mesh you’re showing here.

I notice this too in a basic scene I have, though it’s the shadow of a small rectangular room. Setting the CSM distance to 50,000, with 4 cascades, 20% (0.2) transition region, and a moderate fadeout fraction results in shadows that are there for about half of a cascade. So I start close to the room, back off with the camera, and the shadows fade and dissolve as I get further. Then the next cascade pops in, and fades / dissolves as I get further…until at 50,000 the shadows disappear more abruptly. But at the point before they disappear abruptly, the shape of the shadows look choppy / odd-shaped just before being gone. It happens with CSM distributed closer to the camera and further from camera (exponent). What are the proper settings of CSM for this to not occur?

I know one other option is mesh distance fields combined with the global distance field. Do those result in whole shadows, even at farther distances?

My directional light is movable, increasing the distance did not work but decreasing it did. I’m assuming the size of the mesh affects this?

The shadows are now apparent but they still fade out at a really short distance

Increasing the distance solves this but I get the choppy shadows again.

What you can see there in your picture is a bad static shadow. Have you rebuilt light since changing the light to movable?

I disabled static lighting and it allowed me to push the CSM distance a bit further but the shadow fading is still there but less apparent, the light is in a bp I use for a day/night cycle so building the lighting wouldn’t be ideal since the shadows are constantly moving.

I’ll mark this as answered since I got it to a point where it’s not too noticeable thanks!