Does UE4 / Swarm Require a "D" Drive?


I am currently experiencing issues with building lighting. When I initiate a build, Unreal gets stuck at “Gathering Scene Geometry” I looked toward the Swarm Agent and discovered this error in the log:

2:25:20 PM: [ERROR] Channel registration failed. Reason: An attempt was made to access a socket in a way forbidden by its access permissions
, Callstack: at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)
at System.Net.Sockets.Socket.Bind(EndPoint localEP)
at System.Net.Sockets.TcpListener.Start(Int32 backlog)
at System.Runtime.Remoting.Channels.ExclusiveTcpListener.Start(Boolean exclusiveAddressUse)
at System.Runtime.Remoting.Channels.Tcp.TcpServerChannel.StartListening(Object data)
at System.Runtime.Remoting.Channels.Tcp.TcpServerChannel.SetupChannel()
at Agent.AgentApplication.Main(String[] args) in D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Programs\UnrealSwarm\Agent\AgentApplication.cs:line 133

I see that it appears to be looking for this directory: D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Programs\UnrealSwarm\Agent\AgentApplication.cs

My current machine only has a “C” drive as of right now. I am wondering if a D drive is required and what exactly the swarm agent is looking for here.


Hey there,

Thanks for the quick response. I tried running as admin and have disabled the firewall for a test. It is still kicking out the same error.

Thanks for clarifying the D drive question. At least that is one variable that is out of the question.

Hello -

From the logs it looks like either Swarm does not have administrative permissions on your computer or you have a firewall blocking an needed socket for the computation. I would try to run Swarm Agent as an administrator, then open the editor and try building lighting.

You can also take a look at our Swarm Agent Troubleshooting Guide here:

A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums

The reference to D drive in the logs is from an internal usage of the Program and will have no effect on your build.

Let me know if you need any additional assistance -

Eric Ketchum

Hi idebmatt,

What other steps did you try from the swarm agent troubleshooting guide?

I’ve not seen this particular error before so we’ll probably ask to you try a number of the steps that are already available on the guide.

Also, when you build lighting, does it say that it completes to 100% and lighting is built? If not, do you see a message pop up while in the editor that says “Swarm Failed to Kick Off” or something indicating Swarm Agent did not run?

Have you changed any settings in Swarm Agent’s settings from the default?

Thank you!

Hi ,

So far I have tried cleaning / deleting and validating the swarm cache and log.

Tried Verifying the Engine Version installed on the launcher screen.

I have tried running swarm on its own without building anything.

I have tried this suggestion from another post on the forums:
“Navigate to this folder and delete it’s contents while the editor is closed: C:\Users[Your Computer Name]\AppData\Local\UnrealEngine”

I messed with some settings to try and force swarm to only use this one machine by “Enabling Standalone Mode.” Since playing with settings I have reset them to default.

I have completely uninstalled and reinstalled the Unreal Engine and Launcher twice now.

I have updated Visual Studio, and Updated the .Net Framework.

As for when I run a build, I have yet to see anything that says swarm fails to kick off. It always opens up in the task bar at the bottom. In addition, I make sure swarm is not running when I kick off a build to prevent running multiple instances of it.

When I do build, Unreal just sits at “Gathering Scene Geometry …100%” and completely freezes. I need to force quit that.

Can you post your DxDiag?

Also, can I assume this is happening in any scene you build lighting for or is it for your project?

I’ve uploaded the dxdiag here.

Also yes, It appears to be happening in all scenes and projects including blank ones.

If it is useful, I have not been able to build lighting since the first initial install so this issue did not arise after time spent with UE4.

link text

I’m not seeing anything specifically in your DxDiag that should indicate a problem.

However, I did do a google search for the error your getting and from what I’m seeing this seems to be a network issue and/or a .Net framework issue.

  • Can you try right-clicking on the .uproject or Editor’s .exe file and run as Administrator? This cannot be done from the launcher.

  • Can you also make sure to disable your Firewall and any anti-virus programs you are current running. I know you mentioned you had done this before, but please try this again with administrator access running.

  • If this fails, can you please uninstall any .Net Framework files and re-install the package.

Thanks for the new suggestions once again. Unfortunately I am still seeing the error.

I ran the UE4Editor.exe as an admin and with firewall / antivirus disabled. I found the exe in this directory: C:\Program Files (x86)\Epic Games\4.10\Engine\Binaries\Win64 … I assume that was the right one?

I also uninstalled all of the .net framework files (about 10 different versions just sitting there) and reinstalled the latest which ended up being 4.5.2 and 4.6.1.

After installing, I tried running just swarm as an admin with no firewall and just the editor as admin with no firewall. I am still getting the same error in the swarm agent and the editor is still hanging up on “gathering scene geometry …100%”

Okay, Let’s try this.

Can you open Swarm Agent and in the Settings tab set the Log Settings > Verbosity to Super Verbose.

Then go back to the Editor and for a new Default Level (just the floor and basic scene), can you start building the scene. This should print out to the log in swarm and give much more detailed information.

Hopefully this will have something useful in it that I can see. Just copy all the text there into a text file and upload it here.

If there is already stuff in the log, go ahead and use the Edit > Clear Log option. This will wipe it completely and only get the information for this new scene. Since it’s now set to Super Verbose it will being printing stuff automatically there without a light build, which is OK. just want to make sure there isn’t information from a previous build that I wouldn’t necessarily need.

Thank you!

Alright, here is the swarm log from building on a completely blank level with super verbose logging turned on.

I took the log directly from the swarm cache location here. It appears to me super verbose is not sending out any more information but I could be missing something.

link text

This error can be caused by another application already using the port. The swarm agent uses ports 8008 and 8009 by default, you can see if these are already in use and by what application using the command “netstat -o” or by using the windows Resource Monitor.

You’re right on that one. Not much there to go on.

After some Googling I stumbled across some stackoverflow pages that have this error as well, which is mentions some things about ports not being released that are trying to use the process.

So, with that, I’ve got this application here:

When you run this program (TCPView.exe) you’ll be able to see the processes that are running and the ports that they are using. Swarm Agent should be using 8008 or 8009.

At the top of the program click on the Process tab so that it organizes them in alphabetical order. Then look for the Swarm Agent process. Check to see what the Local Port is being used. It should be 8008 or 8009 from what I’ve seen others reporting and looking at the other machines in our room.

If it’s not using those ports click the Local Port tab so that they are organized in order and see if there is another process that is using either of those ports. If so, depending on the application you may want to close it/end it’s process and see if you can then build lighting.

This program updates every one seconds by default so it may be better to use the option menu for View > Update Speed > and set it to every 5 seconds so it’s not all over the place.

At this point from what I understand with this is that some process is blocking Swarm Agent from being able to run properly, which could be another program, installation issue, or port usage.

Out of curiosity, have you tried any other version of the engine (4.9, 4.11 previews)? If so, did light builds work with those?

Alright, I ran this TCPview with the swarm agent running and swarm is not showing up in the process list. I also see that “System” is running on port 8008 and I do not see any processes running on port 8009.

In addition I have tried 4.7, 4.9, and the 4.11 preview. Same issue with all of the versions.

In checking out these ports and processes in both the TCP view and resource monitor, I see that something just named “System” is using port 8008. I do not see anything using port 8009 and I do not see the swarm process in the list on either the Resource monitor or the TCP view. I have tried this both by running just the swarm agent and by doing an actual build in the editor.

In addition, I tried 4.9 and the 4.11 preview. Both of them gave me the same issue.

I apologize if this reply shows up twice, the forum doesn’t seem to want to show the reply so I’m trying a new comment.

Anyway, I did not see the swarm agent running in either the TCPview or the Resource Monitor. I did see a process called “System” using port 8008 and I did not see any processes using the port 8009.

I have also tried 4.9 and the 4.11 preview. I have gotten the same issue on both.

I looked through the TCPview and resource monitor list. I could not find Swarm Agent in the list of running processes even though it was running. I did see a process named “system” using port 8008 and I did not see any processes using port 8009.

In addition, I have tried 4.9 and the 4.11 preview and still get the same problem.

This is a bit out of my area, but you’ll need to find why that system process is using that port and reassign it if possible to another port so that it can be freed up to use Swarm Agent.

Faced with the same problem Swarm Agent. TCPView showed running NvStream processes that seemed strange. After removal of NVidia Experience app finally it worked.

Thank you for the suggestion.

I haven’t been able to find this app on my machine so I’m guessing that may not be causing the issue.