Ctrl + L does not work UE5 (Unreal Engine 5)

I’m taking a course from Epic Games called “Your First Game in UE5”. Got to the point where the author says you need to press Ctrl + L to start rotate the light, but I have this combination does not work. I checked several tutorials and all press Ctrl + L to start rotating the sun. There is no information about this on internet and I searched in Editor Preferences for keyboard shortcuts but found nothing. (UE5)

5 Likes

You to press CTLR+L and hold it and then you can rotate the light.

11 Likes

Same issue here. I CTRL + L won’t even pull up the arrows.

2 Likes

1)U have a skyatmosphere?
2) if u have a BP_skysphere … try to hide it or delete it

Make sure you have “Atmosphere sun light” ticked in the Directional light settings.

image

5 Likes

I do not know what is happening, but I added Sky Atmosphere and Ctrl + L worked, but it does not move when I spin it back to the starting point. Then when I removed Sky Atmosphere CTRL + L still worked but still not spinning, it just twitches.

1 Like

The author of the course has the sun rotating even without Sky Atmosphere

Yes, it’s checked.

if you create an empty level, put a directional light with the atmospheric light check and put a static mesh and it still doesn’t rotate with ctrl+L, it’s probably a bug

In your Env. Light Mixer, you have to click on “Create Atmospheric Light 0” to create a directional light to make it work. If you don’t have a directional light created using “Create Atmospheric Light 0”, it doesn’t work. Not sure why.

9 Likes

“need to press Ctrl + L to start rotate the light, but I have this combination does not work”

I’m new too, and experienced this. The fix for me was… For SkyLight be sure to enable “Real Time Capture”, and I also made sure to have a DirectionalLight0 in the scene. Now CTRL-L (holding CTRL) let’s me move the “sun” around with mouse.

I found using the Window > Env. Light Mixer let me throw all the things into the scene, then just had to make sure Real Time Capture was enabled on the SkyLight. You must also make sure the DirectionalLight and SkyLight have transform set to “Movable” (that’s the default it appears but in case that got disabled the moving of light source with CTRL-L short-cut not going to do anything since it’s “locked” in place).

6 Likes

I didn’t do all of this, but did go into the transform menu and manually lock, then unlock, the DirectionalLight, and that seems to have fixed it for me. Thank you, the other responses here weren’t solving it for me.

1 Like

Try going to sky sphere and clicking refresh material.
Have a good one

1 Like

This worked for me thanks!

I’m actually experiencing the same issue now. At first the arrow was only twitching, but now it doesn’t even appear. I tried everything you guys said apart from checking if Real Time Capture is enabled because I can’t find it :confused: I tried doing it on different map in the same project and it worked. Only on my new, empty one, it doesn’t. I only have a sphere and DirectonalLight placed there. Bamboozled!

This Worked!!Thanks!! I messed up when selecting directional light on the EnvlightMixer

Hello! I had the same issue, the following worked for me: adding both Atmospheric Light 0 and Atmospheric light 1 into the scene.


So you’ll end up with 2 directional lights. Ctrl + L combination starts working right away. Then, if two suns looks confusing, you can delete the second light. Oh, and don’t forget to press/hold Cttl +L while moving the mouse, otherwise it won’t work. :grin:

I had this problem once in a while, and just realized that my keyboard was not set to US English, which solves the problem.

1 Like

Encountered the same problem, and tried adding “shift” to the combo. It worked.

It appears that each directional light has its dedicated hotkey combination.

Ctrl + L —> Directional Light 1
Ctrl + Shift + L —> Directional Light 2

4 Likes

thank you…