Cooking / packaging Project Freezes

I was trying to package my project when but it kept freezing so I thought that I had to cook it first but it still freezes. There are a couple warnings at the beginning of them but the log just hangs and the editor eventually freezes without any warnings.

Do I need to build my project under something specific ?

*I’m trying to cook a newly created as well but has the same issue.

LogOnline:Warning: No default platform service specified for OnlineSubsystem
LogInit: Presizing for 0 objects not considered by GC, pre-allocating 0 bytes.
LogInit: Object subsystem initialized
LogConsoleResponse:Warning: Skipping Unknown console variable: ‘TranslucentSortAxis = (X=0.000000,Y=-1.000000,Z=0.000000)’
LogConsoleResponse:Warning: Found in ini file ‘C:/Users/Colleen/Documents/Unreal Projects/MyShooter/Saved/Config/Windows/Engine.ini’, in section ‘[/Script/Engine.RendererSettings]’
LogConsoleResponse:Warning: Skipping Unknown console variable: ‘UIScaleRule = ShortestSide’
LogConsoleResponse:Warning: Found in ini file ‘C:/Users/Colleen/Documents/Unreal Projects/MyShooter/Saved/Config/Windows/Engine.ini’, in section ‘[/Script/Engine.RendererSettings]’
LogConsoleResponse:Warning: Skipping Unknown console variable: ‘UIScaleCurve = (EditorCurveData=(Keys=),ExternalCurve=None)’
LogConsoleResponse:Warning: Found in ini file ‘C:/Users/Colleen/Documents/Unreal Projects/MyShooter/Saved/Config/Windows/Engine.ini’, in section ‘[/Script/Engine.RendererSettings]’
LogInit: Selected Device Profile: [Windows]

LogDirectoryWatcher:Warning: Failed to begin reading directory changes for …/…/…/Engine/Plugins/Experimental/CharacterAI/Content/. Error: 0
LogTargetPlatformManager:Display: Building Assets For Windows
LogTargetPlatformManager:Display: Building Assets For Windows
LogSlate:Warning: Failed to load font data from ‘…/…/…/Engine/Content/Editor/Slate/Fonts/Roboto-Regular.ttf’
LogSlate:Warning: Failed to load font data from ‘…/…/…/Engine/Content/Editor/Slate/Fonts/Roboto-Bold.ttf’

*It freezes before I can scroll though the log more

and this is any project but not sure if these warning have anything to do with the freeze

I notice there are 2 UE4 processes in taskmanager and uses nearly 98-100% of my CPU(not sure if that is normal or not)

Anyone might have any ideas? :frowning:

Howdy spazchicken,

Thank you for reporting this error that you have been seeing. I am going to need a bit of additional information before i begin digging into this issue. Would you be able to clarify the build of UE4 that you are currently seeing this error in and if that build is a binary build or a source build?

Would you also attach your DXdiag to this post so that I may be able to further investigate? Any additional information would be greatly appreciated.

Thanks and have a great day!

How do you know how to tell the build differences? Do you mean the project? I’ve tried just blueprints and C++ with the same issue. This is 4.7.3 but when I first started in 4.5 I couldn’t package either but thought I might have been doing something wrong. Also I tried finding cook.txt but could not so wasn’t sure if there was one anymore.

*CPU is ok, it was at 90% and it still froze after a long while.
And thanks for the help! :slight_smile:

[link text][2]

ohhh always from unrealengine.com
you mean copy/pasting from the above image? If so, yeah, until it freezes .
Packaging seems to freeze on the cook part as well

Thank you for the information spazchicken.

For the binary or source question, Did you download the engine though the UnrealEngine,.com website or did you build it from GitHub?

Would you be able to attach the full cooked log as well, if possible?

Thanks!

Would a crash be occurring when it freezes? If so, would you be submitting your crash to CrashReporter?

Also, If you build lighting in your level, does it take a significant amount of time or also cause the editor to freeze?

In the Unreal Projects folder, are there any logs in the saved folder of your project? You can look here to check: UnrealProjects(Project name)\Saves\Logs.

I"ve tried it twice and both stopped at ontent/Materials/M_ColorGrid_LowSpec.uasset,

BUT it’s stopped at other places before

[link text][2]

Ok thanks, link textthis is what is in the logs folder. I’m going to try the light building

no there is no window that tells me that there is a crash. I have to kill UE4 via the taskmananger

I had to allow access from the windows firewall but it only takes a few seconds to build lighting
…wonder if the firewall is causing the issue

EDIT: It went a LITTLE farther but still ended up hanging after killing the firewall

I am thinking that the issue could be related to Windows 8. I asked another member on our team to test this on his PC and he is seeing two instances of UE4 as well. Would you be able to capture a screen shot of the properties of both of those instances?

Thanks!

Sure! However I MIGHT have solved it. I’m pretty sure the Windows Firewall was the culprit. I reloaded the editor after disabling the firewall and lone be hold I was able to cook and package! Packaging would freeze after trying to CNTRL-A a few times to try to copy the entire log while it was processing but If I didn’t CNTRL-A it packages completely. I’m going to try to package my main project just in case before I consider this resolved, Thank you very much for helping!

We’ll I’ve been trying to cook/package my main project but it has taken around 10-20minutes per material/mesh uasset and if i scroll the log it freezes . Is that normal to take that long? :confused: So no I haven’t been able to package/cook my main project. Luckily it doesn’t reload meshes / materials that have already been loaded if i restart it but I still am not sure how long it’s going to finish if ever

10-20 minutes per material does seem like a long time per material/mesh for your project. Since this is the first time that you have packaged your project, it may take a a bit as it is packing all of the assets. How large is your project?

Also, How long did it take to package a template project?

regular was maybe 2-4 minutes total for a new template.

Someone told me to export the project to another computer, how would i go about doing that?

oh ok so you just put it in the unreal project folder ? I’ll just put it on my flash drive then. the computer is in the same house :slight_smile:

this is where I got it from: https://answers.unrealengine.com/questions/200344/packaging-failed-cant-package-473.html

I you go into your unreal projects, you can zip your project up, place it into Dropbox or Google Drive, and then download the project on another PC. This would help to test the issue to see if it could be a hardware problem or possible some other issue.

Just right click on the project folder, send it to a zip file and you should be good to send it your flash drive.

Be sure to let me know how the testing goes.

Thanks and have a great day!

Hey spazchicken,

Just wanted to check in with you and see if this issue was hardware related? If not, please let me know so that I may be able to assist you further with this issue.

Thanks!

Hey sorry for not getting back to you, Haven’t been able to do it as we’ve been out an about :frowning: I’ll be sure to check tonight!

I haven’t packaged it yet because my husband didn’t have visual studio so he’s going to download it today