Download

Built VR in is way darker than preview version. Making it unplayable

So I worked on this game a few months ago, and this ONE bug is making it unplayable. I cannot for the life of me figure it out, and have googled dozens of times but can’t find anything relating to this.

I’m using Unreal Engine 4.27.0 developing for the Oculus quest.
My game, here… when on preview mode, inside the editor OR inside preview on the actual oculus, looks fine, it looks amazing.
However… building it, causes it to be super dark. Like too dark to see. It’s dark when built and played on my laptop, it’s dark when built and copied to be played independently on the oculus.

I’ve added light sources, but still… always dark.

(ignore the debug logs in the screenshot on the right, they just happened to be there when I took the pic)

Hello. Have you already fixed this? I am facing the same problem as you and don’t know how to fix it :frowning:

When you’re working in editor, or previewing in VR on your PC, the entire rendering path is different than what you’ll see when you deploy the application to your Quest. For a “true” image on what your scene will look like on the Quest, you have to enable either ES3.1 or Vulkan Preview Rendering Level in the editor: Mobile Previewer | Unreal Engine Documentation

If you’re using the VR Template in 4.27 and later, it’s already been preconfigured to use Vulkan as the mobile rendering API, and that’s the Preview Rendering Level you should use in Editor if you want to know what it’ll look like on Quest.

I hope that helps!

1 Like

Not yet :sob: if YOU find a fix, tell me. Cuz Idk what’s wrong or what is even causing it.

Oh… any way I can “brighten” up the scene? I haven’t swapped over to Vulkan, but I assume this would just make my desktop preview show me what it looks like on quest. but that doesn’t solve it being super dark.

I’ve tried adding EVERY kind of lighting but none brightens up the world enough.

As Victor mentioned before, make sure you are using Vulkan Rendering in the editor, and use the Mobile Previewer. Also make sure that your lights are static and not dynamic, i would recommend you to check lighting limitations on mobile: Lighting for Mobile Platforms | Unreal Engine Documentation

Hope it helps!

I’m having a similar issue, thought perhaps the opposite as the original OP, with the way UE displays Vulkan preview in relation to the way it builds.

Using the default VR template, no changes other than ticking Settings > Preview Rendering Level > Android Vulkan.

As seen in attached images, the editor displays Vulkan with a bit less contrast, greyer blacks. Much as it is rendered when built to headset (shown in the middle frame of the second attached image).

But when Played using VR Preview, Vulkan is much much darker. Far darker than it is actual rendered when built to headset. It is so dark that it isn’t even a usable preview in my personal level because I don’t have as much bright sky as this template.

Is this expected behavior? Am I missing something @VictorLerp ??