[BUG] Debug Symbols for Plugin only load if LoadingPhase == PreDefault

Tested in VS 2019 and VS 2022 (community), debug symbols (pdb) files do not load for my plugin. VS looks for the pdb file inside the engine binaries folder instead of the plugin folder of my project. Massive waste of time trying to solve this, why does this happen? I already cleaned the entire project multiple times.


Figured out that symbols are not loaded at all for a plugin depending on its .uplugin configuration. Take the following config:

	"FileVersion": 3,
	"Version": 1,
	"VersionName": "1.0",
	"FriendlyName": "PluginName",
	"Description": "PluginName",
	"Category": "PluginCategory",
	"CreatedBy": "Seda145",
	"CreatedByURL": "",
	"DocsURL": "",
	"MarketplaceURL": "",
	"SupportURL": "",
	"CanContainContent": false,
	"IsBetaVersion": false,
	"IsExperimentalVersion": false,
	"Installed": true,
	"Modules": [
			"Name": "AssetValidatorPlugin",
			"Type": "Editor",
			"LoadingPhase": "PreDefault"

As long as the LoadingPhase is set to PreDefault, pbd files will be loaded and debugging will be possible. Any later state (which would obviously be preferrable) is impossible to debug as the pbd files will be skipped.

Keeping this question unsolved in case someone can tell me what this behavior is.

Works for me in 4.26 built from source. Although I don’t think I have the "Installed": true entry in my uplugin file. Are these Engine plugins or project specifc ones?

I didn’t notice a difference when using “Installed” : false, afaik the plugin worked anyhow. It is a plugin I made myself, stored in the project folder, not the engine folder.

@UnrealEverything try setting the LoadingPhase to PostEngineInit, you’ll see the symbols won’t be loaded.

In VS 2017 Community "LoadingPhase": "PostEngineInit" also works. I just changed one of my Plugin Modules from "LoadingPhase": "PostConfigInit" to that. According to the Debug Output its symbols were successfully loaded. Unfortunately I don’t have VS 2019 or 2022 installed currently so I cannot test those right now. What configuration are you using? I tested with Debug Editor.

Have you tried changing any of these VS settings yet? Symbol / PDB files in the Visual Studio debugger | Microsoft Docs

1 Like

I’m having the same issue with VS 2022. Building in Development Editor mode. So far I tried adding the pdb dir manually as described on your link but that does not work. The symbols for my plugin only get loaded properly when LoadingPhase is set to PreDefault.

Related post: