All of my actors except a few suddenly say [Unloaded] and are hidden, what is this?

Hello,

I’m on the ue5-main branch of the source build. I was working with a mesh particle emitter in Niagara, and my viewports and sometimes UI were locking up for some reason. I decided to close out and reopen UE5. Upon doing so, all of my actors except for foliage, sun directional light, post process volume, skylight, sky atmosphere, fog, a few landscape actors, and my playerstart, so that means all blueprint actors and static mesh actors etc., all say (Unloaded) next to the name in the World Outliner and are grayed out. Their folder organization is gone as well. I’ve never seen this before, nor do I know of any way to “unload” actors. Right clicking gives me very little options.

  • My game plays fine in PIE etc., it’s just in the editor that this happens.
  • I found out that if I pin one, it will “load” in and I can see it in the viewport and its (Unloaded) status goes away. Unpinning it makes it “unload” again. I can select every actor and pin it to get it all to show up. Restarting the engine will cause them to revert to their (Unloaded) state, so I don’t want to do that every time I load up the project, as restarting will reset them to be (Unloaded). Reopening the map will cause the actors to revert to being (Unloaded) as well.
  • I also rebuilt the engine after pulling the newest from ue5-main, thinking the engine just had a stroke. Unfortunately it didn’t fix it.
  • I tried opening a duplicate of the map, and that duplicate is entirely empty!
  • I tried copying all the actors into a new map. They display without being pinned. Reopening that map: it’s entirely empty! Except for an “unloaded” Brush actor or something??

I am using World Partition, so I had a hunch that’s what caused it, since that handles “unloading” and “loading” of actors right? I’m not using Data Layers.

As I’m unsure if this is a bug or not, I thought I’d just ask here if there’s a way to revert these to a loaded state permanently without pinning them every time.
Thanks for any help you can provide, and if this is a bug please let me know and I’ll file it as a formal bug.

Edit:

Forgot to say: my layout (while default, mind you) got extremely jumbled up. I reset to the default and now it’s fine. There was a few other odd things like errant behaviour from certain things but I can’t attribute it to that fateful restart.

In general, everything seems to be working less swimmingly after this all started happening. More crashes, etc.

Added an image:

3 Likes

Did you check what your settings are in the actors’ details under World Partition? Is it set to Location or Always Loaded?

1 Like

did you ever figured this out? I have the same “issue”, what could be?

3 Likes

nevermind I made it work. in the world partition window you drag a selection over the part of the world you want to have loaded then right click and select “Load Selected Cells”

13 Likes

Yes that’s exactly the answer. You need to drag select.

2 Likes

Sometimes, it doesn’t work. All the cells are loaded but not an actor or two.

4 Likes

this bug is serious

5 Likes

After a long session building assets, and just after a save, everything suddenly disappeared from the edit screen. All the assets were still in outliner - but greyed out - and with the tag (UNLOADED). Right clicking gave me an option to paste - and i tried that - to see the assets reappear briefly in time for the Engine to crash. I had saved the assets before any problems - so i reloaded. No assets visible in the editor - but they were still in outliner, greyed out with the tag (UNLOADED). This time i didnt get the option of pasting.
Thanks for the ‘pin’ tip - saved me half a day’s work. Pinning one of the items triggered a play instance for me, with my assets loaded in the instance. I went in, grabbed them and ran.
Cheers

2 Likes

World Partition Cells not unloading properly

Jeez, I be failing at the very basics here…
Thanks for the tip! You solved my problem!

Thank you so much this worked for me.

hi, What is the best practice? I am having the same issue

For anyone having this issue, clicking on the pin next to my greyed-out assets in the outliner brought them back for me. On UE5.02

1 Like

Pin doesn’t work for me on 5.03 :disappointed_relieved:

in the world partition window you drag a selection over the part of the world you want to have loaded then right click and select “Load Selected Cells”

Just to reiterate, this is the only proper solution to this issue. The “pin” thing is temporary. Open the World Partition window, drag a box over your world, right click and click “Load Selected Cells”. Any bugs occurring after doing this are likely caused by something else.

1 Like

I came across to this now too, seemingly random assets remain unloaded. Pinning them works for me though, using 5.03.

Even as the pin works, I’d like to know why it’s doing this? What causes it, so I could avoid problems in the future.

Thanks! This solve the issue for me as well.

To support the development of large worlds, all grid cells are initially unloaded. When the Level opens, the Editor will only load Actors that have their Grid Placement setting marked as Always Loaded, such as environment backdrops and managers. This supports the development of large worlds where it is impossible to load the entire map in the Editor.

In the World Partition window, you can manually select which grid cells to work in. Open the window by selecting Window > World Partition from the main menu.

In the window, click and drag grid cells to select them. Then, right-click the selection to open the context menu to load and unload the cells.


Here are what the Unreal official documentation says about the issue, why and how to fix.

Seems to work for me thank you very much

THANK YOU! This is something Epic Games should fix its annoying.