World Partition Cells not unloading properly

im having an issue with world partition cells not unloading properly for me. i tried as many tricks up my sleeve as i can with no success. the problem also persists across multiple new projects and configurations.

problem: when having a world partition with multiple cells, flying away from the landscape unloads almost all the cells normally exept a couple that remains loaded forever in a + sign shape across the entire landscape.

demonstration:


what could be causing this issue? and has anyone found a fix?

2 Likes

No
I have the same problem.
New Landscape 1x1km, 8x8 comp / proxies

And here a 8x8km map from far away

a little closer

and little closer

1 Like

Hm, couldnt edit my post.

Forgot this test map. Its 40x50km

2 Likes

I have a similar problem…some of my landscape-tiles remove themselves when pressing play and won’t load in when i am near them.
But in Editor, i see can see everything.

1 Like

Have you ever tried these options:

1 Like

Yup. Doesn’t change anything for me (if you meant me).
If i de-check Streaming in World Partition, it all shows up.

i definitely made sure my cells are loaded/unloaded properly and saved in world partition tab. thats the first thing to do really, basic stuff. as for the visibility option in the outliner, it shouldn’t have to do with anything, because it’s only for the editor side. once u go in runtime, it all reverts to the default states no matter what u show/hide in the outlier. it has no effect for me.

Got it, I’ll post here if I find anything.

@Sebastian_OK
you’re 40x50km screenshot is interresting. it reveals that once you go with a massive enaugh tiled landscape, it’s no longer just a + sign pattern of cells that refuse to unload, but rather an entire grid pattern of cells that refuse to stream out.

1 Like

Same issue here as well. Just missing chunks lol

That’s no ordinary “grid pattern”. That’s a quadtree. Those are used to speed up certain kinds of operations (e.g. finding the nearest neighbor of something).

They’re probably using them to speed up finding the tiles within range. What’s interesting is that the tiles within each cell of the tree get culled. It’s the tiles which are on the dividing lines of the quadtree that remain.

1 Like

ya, that help :grinning::pray:

Did anyone find a solution for this?

i still have the same problem, there has been no fix so far. im just ignoring it for the moment and hoping maybe 5.1 will have a fix.

luckily in my game i have an alien snowy huge landscape, and the density of the fog and snow hides the landscape chunks that dont unload and float in air in the distance. but it’s still a problem that needs fixing. i hope the devs will notice.

To this day there is no a solution for it?

I have the same issue as well with a 16x16 km. Just commenting to try to keep this thread alive so hopefully the problem is noticed. The Grid preview also looks really weird in the editor, constantly shifting just by looking around

1 Like

I’m having the same behaviour on 5x5 test map (see first video below).

Initially I had naively assumed that terrain streaming/culling was affected by cell size set in Runtime Settings But I’ve realised that simply controls meshes/objects that are scattered across the terrain rather than affecting landscape streaming proxy’s themselves.
image

Can anyone confirm the way UE5 set’s the distance for culling on these landscape proxies - and is this configurable?

If the streaming/culling behaviour is not working at the moment, has anyone found a method to at least load all terrain proxy’s at once?

When testing a terrain that is split into 12 x 12 LandscapeStreamingProxy’s - I get more erratic loading of tiles:

My mistake - I mentioned the wrong config setting above! - Cell size is irrelevant re culling landscape.
I now understand that you have to bump up the Loading range which does affect the landscape proxy tiles. however it’s still a little odd that tiles remain outside the zone of the loading range, I think several people have mentioned this issue, loading all the tiles to avoid the messy look is not great from performance perspective.
image

Not sure if anyone has resolved this. But does anyone have this issue when the game is running standalone? i.e. Compiled game? I have this problem on my level but once the game runs for a bit all of the tiles load in and the game is fine.

It appears in my case it is simply an issue of not enough video memory. Running the editor, all of my other apps (including streaming my security cameras on same system). I get results (debug is on) that my memory is exhausted (and I am too).

So is this something that might be present only in the editor, not necessarily a released game? I am not at the point of compiling yet but would be interested in knowing if there is an issue.

Uploaded a Youtube Example. Notice everything finally loads then I get the memory warning.
https://www.youtube.com/watch?v=WsmYtJp9M7I

we are propably experiencing a different problem from yours in this thread. i also get some tiles that dont load fast enaugh sometimes but thats an obvious memory issue wich im not too worried about.

the issue we have here is propably caused by the world partition tile system, where some tiles of the landscape dont UNLOAD when we’re far enaugh from them and remain visible and in memory forever in an ocrtee pattern. these tiles will never unload no matter how much memory u have or how long you wait. i can confirm that the problem also exists when the game is packaged.

im curious if only some people have this issue or everyone? if you have a landscape split into multiple tiles in world partition, can you confirm that you’re landscape completely unloads when you fly away from it? or does some part of it always remain visible?