All of my actors except a few suddenly say [Unloaded] and are hidden, what is this?

Did you check what your settings are in the actors’ details under World Partition? Is it set to Location or Always Loaded?

1 Like

did you ever figured this out? I have the same “issue”, what could be?

3 Likes

nevermind I made it work. in the world partition window you drag a selection over the part of the world you want to have loaded then right click and select “Load Selected Cells”

13 Likes

Yes that’s exactly the answer. You need to drag select.

2 Likes

Sometimes, it doesn’t work. All the cells are loaded but not an actor or two.

4 Likes

this bug is serious

5 Likes

After a long session building assets, and just after a save, everything suddenly disappeared from the edit screen. All the assets were still in outliner - but greyed out - and with the tag (UNLOADED). Right clicking gave me an option to paste - and i tried that - to see the assets reappear briefly in time for the Engine to crash. I had saved the assets before any problems - so i reloaded. No assets visible in the editor - but they were still in outliner, greyed out with the tag (UNLOADED). This time i didnt get the option of pasting.
Thanks for the ‘pin’ tip - saved me half a day’s work. Pinning one of the items triggered a play instance for me, with my assets loaded in the instance. I went in, grabbed them and ran.
Cheers

2 Likes

World Partition Cells not unloading properly

Jeez, I be failing at the very basics here…
Thanks for the tip! You solved my problem!

Thank you so much this worked for me.

hi, What is the best practice? I am having the same issue

For anyone having this issue, clicking on the pin next to my greyed-out assets in the outliner brought them back for me. On UE5.02

1 Like

Pin doesn’t work for me on 5.03 :disappointed_relieved:

in the world partition window you drag a selection over the part of the world you want to have loaded then right click and select “Load Selected Cells”

Just to reiterate, this is the only proper solution to this issue. The “pin” thing is temporary. Open the World Partition window, drag a box over your world, right click and click “Load Selected Cells”. Any bugs occurring after doing this are likely caused by something else.

1 Like

I came across to this now too, seemingly random assets remain unloaded. Pinning them works for me though, using 5.03.

Even as the pin works, I’d like to know why it’s doing this? What causes it, so I could avoid problems in the future.

Thanks! This solve the issue for me as well.

To support the development of large worlds, all grid cells are initially unloaded. When the Level opens, the Editor will only load Actors that have their Grid Placement setting marked as Always Loaded, such as environment backdrops and managers. This supports the development of large worlds where it is impossible to load the entire map in the Editor.

In the World Partition window, you can manually select which grid cells to work in. Open the window by selecting Window > World Partition from the main menu.

In the window, click and drag grid cells to select them. Then, right-click the selection to open the context menu to load and unload the cells.


Here are what the Unreal official documentation says about the issue, why and how to fix.

Seems to work for me thank you very much

THANK YOU! This is something Epic Games should fix its annoying.

Hi, there. How does one “draw a box” over the world in the World Partition tab? Left click and drag does nothing. Is there something I’m missing?

1 Like