Wrong textures with Nanite

Hello, I have a strange error regarding the textures with nanite.
When I open my project some of the meshes that use nanite have the texture of some other mesh (which also uses nanite).
If I select that Mesh the texture goes back to the correct one. BUT if I run my project in the editor sometimes that mesh has the texture of another mesh again.
This also happens when I build and package the project (doesn’t matter which configuration).
It seems to happen very randomly since the textures which are shown on the wrong mesh also change after almost every time I run the project in the editor.
After I press ESC and return back to editing in the editor the correct textures are displayd again.

CORRECT:
image

WRONG:
image

I have virtual textures turned on but it also happens when they’re turned off.

This also occurs when I create a new project.

Does anyone else have this problem or knows a solution/workaround?

Thank you in advance.

1 Like

I’ve been experiencing the same issue :joy: I hope the next version can be fixed…lol

Solution:

Megascans object material issue - Development Discussion / Unreal Engine 5 Early Access - Unreal Engine Forums

1 Like

cool~solved after skylight setting stationary to movable,thanks you!!,before i trying to modify virtual texture and nanite settings,but is always wrong,maybe skylight setting stationary, lightmap in lumen not update bug. thanks again!!

1 Like

UPDATE: Ok so i‘ve found the problem. You can either remove the sky light or in the sky light there is a setting under LIGHT named Real Time Capture. Activate this setting.
Select everything (so everything shows the correct textures and materials).
Then in the skylight scroll down and under SKYLIGHT press recapture.
From there on out the problem has not reoccurred anymore even after adding more nanite meshes.

With these changes in the settings it also didn‘t matter if the skylight was stationary or moveable etc.