World Partition Cells not unloading properly

I have the same issue as well with a 16x16 km. Just commenting to try to keep this thread alive so hopefully the problem is noticed. The Grid preview also looks really weird in the editor, constantly shifting just by looking around

1 Like

I’m having the same behaviour on 5x5 test map (see first video below).

Initially I had naively assumed that terrain streaming/culling was affected by cell size set in Runtime Settings But I’ve realised that simply controls meshes/objects that are scattered across the terrain rather than affecting landscape streaming proxy’s themselves.
image

Can anyone confirm the way UE5 set’s the distance for culling on these landscape proxies - and is this configurable?

If the streaming/culling behaviour is not working at the moment, has anyone found a method to at least load all terrain proxy’s at once?

When testing a terrain that is split into 12 x 12 LandscapeStreamingProxy’s - I get more erratic loading of tiles:

My mistake - I mentioned the wrong config setting above! - Cell size is irrelevant re culling landscape.
I now understand that you have to bump up the Loading range which does affect the landscape proxy tiles. however it’s still a little odd that tiles remain outside the zone of the loading range, I think several people have mentioned this issue, loading all the tiles to avoid the messy look is not great from performance perspective.
image

1 Like

Not sure if anyone has resolved this. But does anyone have this issue when the game is running standalone? i.e. Compiled game? I have this problem on my level but once the game runs for a bit all of the tiles load in and the game is fine.

It appears in my case it is simply an issue of not enough video memory. Running the editor, all of my other apps (including streaming my security cameras on same system). I get results (debug is on) that my memory is exhausted (and I am too).

So is this something that might be present only in the editor, not necessarily a released game? I am not at the point of compiling yet but would be interested in knowing if there is an issue.

Uploaded a Youtube Example. Notice everything finally loads then I get the memory warning.
https://www.youtube.com/watch?v=WsmYtJp9M7I

we are propably experiencing a different problem from yours in this thread. i also get some tiles that dont load fast enaugh sometimes but thats an obvious memory issue wich im not too worried about.

the issue we have here is propably caused by the world partition tile system, where some tiles of the landscape dont UNLOAD when we’re far enaugh from them and remain visible and in memory forever in an ocrtee pattern. these tiles will never unload no matter how much memory u have or how long you wait. i can confirm that the problem also exists when the game is packaged.

im curious if only some people have this issue or everyone? if you have a landscape split into multiple tiles in world partition, can you confirm that you’re landscape completely unloads when you fly away from it? or does some part of it always remain visible?

Hey everyone,

The team is aware of this issue and plans to have it addressed by 5.1.

-Ryan

4 Likes

i have also made a bug form here : Unreal Engine Issues and Bug Tracker (UE-151797)
but no fix till now…

1 Like

here is a bug demo

Hello, I have the same problem and waiting for a fix

1 Like

thank you ryan, this is really good news! this is exactly what i was hoping to hear.

Thats all the proof anyone ever needed to treat this as a bug: A perfect octhedral shape from remaining border cells.

Octhedral loading shouldnt just be locked to the the world center, it should travel with the actor/camera and rebase itself form the new location.
No wonder the engine gets 10fps…

I encountered the same issue.

Had the same issue on a much smaller map, I unchecked “enable streaming” and everything is loaded. I don’t think this fixes the issue, but works as a temporary solution until they fix the bug
image

1 Like

I have the same issue currently, happy to hear that it’s being worked on because world-partition + landscapes just seems like a broken feature at the moment.

So there is still no fix for this? :confused:

Hi,
as @RyanBickell said, the bug will be fixed in the 5.1 release, till there I guess you can work with enabled streaming unchecked and wait for the new release.

hi everyone,

unreal engine 5.1 preview is released and i went and did some testing for this issue. i can happily confirm that the problem has been fixed. maybe this will require some further deeper testing but so far i’ve been getting good results.

all the landscape tiles unload properly and only the tiles in the immediate range that you setup in streaming settings are loaded.

it goes without saying, it’s only a PREVIEW version, we will have to wait and see for the full final release. but good job Epic team :+1:

Hello, hello!
I’ve been pulling my hair out all afternoon, until I found this thread :smiley:
I thought I must be doing something wrong, but it looks like it’s actually just really, really buggy right now?
Just posting here to keep the thread alive, because I can’t get WP to work predictably at all.
I tried WP in 5.0.3, creating a new map and converting an old map. Tried the same thing in 5.1.0 preview. Always the same results.

I basically just create an array of 1m cubes which sit on an array of 30m planes.
Everything streams in an out unpredictably.

Some cubes remain visible the entire time, same with the planes… Just won’t cull.
When I start moving, random planes and cubes pop into view, even way beyond the distance I had set. I move backwards, some won’t cull anymore.

Lighting setup I had done via Env Mixer won’t load at all after play start (neither ingame, nor in editor after exiting), needed to use the little pin icon to get them back.

The world partition mini-map display is also breaking for me in 5.1.0, permanently displaying the click/drag selection outlines (when trying to select regions to load in) etc etc. :smiley:
Oh and sometimes the editor crashes altogether when I try to view the 3D debug. :sweat_smile:

In this state I find WP totally unusable… but it really seems to work ok for some people. Any thoughts at all why it works for some users and not for others?

Nonetheless, great stuff, love UE :heart:

made a quick little recording as demonstration of the system working as intended in 5.1 preview.

the landscape chunks get loaded properly when in range (green cells) and unloaded but remain in memory (purple cells) and finally fully unloaded ( red cells). no octree pattern of unloaded mess remaining.
this behavior was completely missing before 5.1 preview. this was the main topic of this thread wich now seems to be solved.

I mean… is it octree? Does it now support vertical loading?
Quadtree otherwise.

I’d love it if it supported vertical loading, but I doubt it does?