Widget button not working most of the time

Hello, I created a widget and it seemed to work fine in another UE project. After recreating the same in another project (with more and larger assets) the widget seems to work far less, about one-tenth of the time as a guesstimate. I’m having a hard time doing brute-force troubleshooting as well as it crashes every now and then. I’m quite the beginner and I’m not sure whats causing the issue and why it works sometimes(albeit rarely for…no seemingly apparent reason).
What would happen is that when I hover over the button, it does appear to not show the UE default hover state UI very well unless I aim at certain parts of the button, but even clicking at those parts, nothing happens. Unsure if this is a symptom of the issue as well.
Could it be the way my Primary Actor BP components are arranged/nested? or the sequence the nodes are called?

VRPawn - Edited trigger button to interact with widget

Primary Actor BP - for Widget Display and Interaction

Primary Actor BP - to initialize Video

Primary Actor BP - to make video panel appear

Expand Widget Button - to make video panel appear

Tutorials Used
Create and Interact with UI for Virtual Reality - Unreal Engine Virtual Reality Tutorial - YouTube to configure pointers and interactability (Trace Channel=World Dynamic).
How To Make An Interactable 2D TV In VR using UE4 - YouTube to set up widget with video player.

AMD R5 5800

Let me know if you need any additional information. Thanks!

When it does work once, close then reopen without changing anything, this is the crash report that I get.

Hey there @laylayover! Are the on hover events firing inconsistently or just the onclick events? You mentioned the UI was finicky about receiving the hover, could there be any other object obscuring the trace?

Try popping some breakpoints and print statements on each step to see exactly when it’s failing and how, it’ll likely point in the correct direction.

In reference to the error and crashing you receive, that’s more of a separate graphical issue. This could be a TDR issue or more, since you’re working in VR you’ve got lots more overhead than standard projects, and working from a laptop likely compounds this. I’ve got a couple of bandaid fixes over here on a separate post:

1 Like

Hello! Yea i think it was something over overlapping that made it buggy. I deleted something…that didnt seem like it was overlapping but then it worked haha.
Also i tried the solution for “GPU crashed” and it seems to work so far, no crashes for the day. Thanks!!

1 Like

Hi Laylayover,

Could be unrelated, but I noticed something strange in your first image: the button in your ‘Release Pointer Key’ function is not defined! (It should also be LMB)

1 Like

Oh yea youre right! Fortunately its already working and yes my latest script already has that. I suppose that would likely have been the culprit. Thanks!!!

1 Like