Why is NavMesh Bounds Volume not displaying Green?

Hi guys. I have a Nav Volume coming through a static mesh, but no matter how many times I build or press “P” it doesn’t show the green navigation flooring (or red for that matter). Which is very odd, because I have no trouble getting this to work in a demo map.

This is what I am attempting to accomplish: http://docs.unrealengine.com/latest/INT/Engine/AI/BehaviorTrees/QuickStart/2/index.html

My first guesses would be to check the properties of the mesh and to manually build navigation.

What mesh properties should I be looking for? As of right now, it’s just a default Cube. So is the NavMesh.

I actually only need the enemy to follow and navigate towards the player character on the x-axis, as it’s a sidescroller game. Do you know a better solution to achieve this?

Is collision and can step on set to block all and true?

You could go old fashion and do velocity and position yourself. Get the player’s X, the Enemy’s X, and interpolate them.

That did it! Changing the collision on the static mesh from Default to BlockAll got it working. Can Character Step Up On was and kept enabled.

Thanks!

As NoobsDeSroobs pointed out, the static mesh need collision. I set it to BlockAll and that did it. Thanks NoobsDeSroobs!