Why is my lighting not rebuilding?

Hello everyone.

Okay, so I’ve had a nice little play around with the engine, so far am impressed with it :slight_smile:

Anyway, I have mainly doing random odd stuff to get myself familiar with the UI and what does what and I am slowly building confidence.

So, last week or the week before, I decided to muck around with building my own basic arena map to which in future I’d like to add in gameplay mechanics like guns and so on, anyway to the problem.

I tried doing a lighting rebuild to see what all my lighting looks like once rebuilt with production level to see if I like the look of all my directional and point lighting and to see where changes can be made or adjusted, anyway, the first time I decided to do it I got the box come up that I think says “Starting rebuild” or to something of that effect, but very quickly disappears, I get no error message, the box just opens and than very quickly closes.

I have tried started up Swarm agent manually and re-trying but same thing.

I have cleaned up the map a bit as there some extremely messy areas and bits that stuck under the map, so I thought if I cleaned that up it might fix it, but nope, still does the same thing, I then made up a test map and made it messy as I could to see if that would cause issues with it, so I did that, set the lighting to production level, and viola, it works.

So it is obviously a problem with the map, but I just cannot for the life of me figure it out, and any help would be great because at the moment, I have thrown in the towel and cannot think of what might be causing the problem :confused:

I am using version 4.3 if that helps.

Thanks in advanced for any help, it would be greatly appreciated.

Sooo… No one knows what’s going on?


In your level what are you using to populate it? Are you using static meshes included in the starter content, Geometry/BSP brushes, or your own created assets?

Is your directional light in your scene set to Movable or Static? If it’s movable it won’t bake any light information as it will be casting fully dynamic shadows. This could cause the “build” to flash on and the disappear.

When you started your level are you creating a new level with the default or blank map? Either way, you’ll want to make sure that you’re including a Lightmass Importance Volume that encompasses your playable area.

Also, depending on how much light information is needing to be baked it can determine how long the light build will take.

Let me know and we’ll figure out what’s going on. :slight_smile:



I am just using all the standard stuff included in the starter content, and for things like boxes, stairs etc I am just using the standard brush and not my own contents.

I do not remember how I started it, I think I started it using the basic FPS code from memory.

How do I check if the directional lighting is set to movable or static?

You can see if the mobility in the details panel that would be on the right side. When you select the directional light from the scene outliner you’ll see the properties for this light appear there. It’ll be towards the top where it says “static/stationary/movable.”

Thank you.

What should I have it set to?

I had a bit of a play around with it, tried it on movable and changed the lighting build to production, I could see the textures do something but it didn’t look like the lighting was built in production level and the same thing still happens.

I also changed some of the objects that have the option to change them to static stationary etc and put them to movable but same thing.

Honestly, this depends on your goal for your project. If you want a dynamically lit game where all the shadows are created at run-time (can be performance hit if those movable lights are set to cast shadows) then you would want the lights to be Movable.

If you’re using stationary (a combination of static and movable) or static this will require you to have a second UV for your meshes for the lightmap to build and bake the lighting to.

Okay, so changed the lighting into static without changing objects like walls etc into static and the map goes black, so I change objects to static and do a lighting rebuild and everything lights up again, but it still does the same thing where the lighting rebuild won’t go through the full process.

Do you want me to do a cook and post the log file? Maybe that could help us find out what could be causing this?

You can post those if you like.
Can you make a video and post as well?

Maybe some screenshots. Something to visually give an indication of what’s going on?

Can you also confirm if you’re using a lightmass importance volume that is covering your entire playable area? If not, make sure to add one.

Thank you!



Since I’ve not heard from you in a few days I’m going to mark this as resolved for our tracking purpose. If you’re still having the issue please provide the information request so I can further look into this.

Thank you!