Why is CurveFloat Failing on import?

Created a blueprint with two lights. The light brightness is being driven by a timeline animation float curve. It works great for flickering lights. Once the original light blueprint was complete and functioning as expected, I then duplicate the blueprint so that I can change the animation phase of the light flicker curve for the second light. It worked great, until I reopened the editor. Now, for the duplicate blueprint, I get an error on import and the blueprints timeline animation curve disappears. Therefore, my lights don’t flicker and the new blueprint class doesn’t function properly.

Error Failed import: CurveFloat /Game/Blueprints/FlashingLight.FlashingLight:CurveFloat_0_1 in /Game/Blueprints/FlashingLight3

Error Failed import: CurveFloat /Game/Blueprints/FlashingLight.FlashingLight:CurveFloat_0_1 in /Game/Maps/Minimal_Default

I tried completely rebuilding the timeline from a duplicate of the original blueprint. I tried renaming the timeline and it’s variable. But upon reload, no matter what I do, the animation curve within the duplicated blueprint timeline, always disappears. Any help would be appreciated.


Well, have got the same problem. Got some lamps with brightness on timeline and each time I load a map with them, I got a import fail on some of them. Any idea?

i had the same issue, after i clicked Edit.DeleteUnusedVariables in the blueprint editor the problem disappeared. Give it a try maybe it helps.

Same issue here, first only one level and then the next. May indeed have to do with timeline I’m not sure.

As Gigantoad mentioned this does seem to be Timeline related.

I reproduced it by creating a timeline in my character blueprint and deleting it. The next time I started the editor I would get an error that the curve was missing. It is worth noting that at the same time I was also facing an issue where my game would crash as soon as I hit ‘play’.

Both the curve error and the crash issue were resolved after I deleted my playerstart from the level, placed it again and added a new timeline to my character blueprint to replace the one that was deleted. (I think the same solution was reported in the forums somewhere as well but I’m not sure why this works)

It went away when I did a Edit > Delete Unused Variable. Never deleted a Timeline so I don’t know what’s going on there.

This worked! Thank you so much, I’ve had this issue with timelines for a while now.

I suggest this be marked as the answer by OP or support staff.

I Found that renaming the curve within the timeline fixed this for me. Not the timeline but the actual float curve within it.

Thx Skos That fixed it for me!

I still get these errors cropping up in 4.8 when we copy and paste timeline nodes. Is this fixed in 4.9 or 4.10?

I fix this only changing the name of the timeline