Why do the inside of the light shades only pick up light when set to stationary or mobile?

There are no moving lights in the scene, I want these downlighters to be static. When I set them to static and bake the lighting the interior of these lightshades goes dark as if there is no light inside of them. The only time they look lit on the interior is when the spotlights are set to stationary.

Here is an image of what it looks like when they are set to stationary:

Here is an image of what it looks like when they are set to static and then baked:

I want it to look like the first image except with static lighting.

If for some reason you choose not to answer my question, please at least explain why you don’t want to, or what I have done wrong on this forum. I have asked two previous question and received no answer, so I’m not sure who I offended or what mistake I made.Thanks

I highly doubt there is any malicious intent if people don’t answer your questions. More likely, the people who look at your questions don’t know the answer. I’ve come across many unanswered questions on Unreal Answerhub compared to, say, Unity Answers, and it’s rather frustrating. Possibly simply because the userbase of Unity is so much higher.

I’m afraid I don’t know the answer to your question, but I’d be interested in knowing if ANY light appears on those meshes with static lighting - try moving one of the lights outside the mesh and see if it lights the outside.

Ultimately you will get better quality of lighting with non-static for the shades themselves. Is it possible to use a static light for the room lighting but a small-range stationary light simply to light up the inside of the lamp?


Your stationary scrrenshot shows an unbuilt scene… does it look the same after build?
Could you show us your material settings for the inner side of your lamp?
Also could you show us your second uv channel for the lamp?
…and your lights settings…

Thank you for the reply.

I did not mean to imply malicious intent, I just thought that perhaps I was not following community guidelines or something.

I managed to solve the problem. It was as simple as unwrapping the UVs correctly

Thank you for your reply.

You got me onto the right track by mentioning the UVs. Not sure why I didn’t think of that, I was just being lazy I think XD

Solved the problem by correctly unwrapping the UVs