Why do shadows look wrong with transitions between meshes?

As you can see on the picture, transition looks really sharp. How can I fix it?

This is because you’re using modular floor pieces. When light is baked it is baked on different threads that leads to this shadow seam between meshes.

There are several ways to alleviate this but it will not necessarily get ride of this completely because of the way rendering is handled.

First you will need to make sure that when you make your lightmap for your mesh you are making sure that the vertices are snapping to the grid in your UV unwrap. You’ll need to make sure that you target a specific LM size and set up your UV grid accordingly.

For instance, If you’re targeting a 128 LM resolution you’ll want your grid spacing in your UV Grid to be 0.0078125

You get this number by doing the following: 1 / [ LM Resolution ] = Grid Spacing

You can find more information about Lightmap tips and tricks here.

Secondly, for your scene you’ll want to make sure that you have a lightmass importance volume in your scene.

Then go into World Settings > Lightmass > Change Indirect Lighting Quality to 2 or Higher (This will increase light build times) and change the Indirect Lighting Smoothness to something around 0.6.

It may also help to change the Environment color to something other than Black. This will soften your shadows and help with the shadow seams as well.

You can also find more information in this thread:


Thank you!


1 Like

It works! Thanks!

1 Like