Why do my static lights not showup after a light build?

All my lights show up in the light build if they are set to stationary, but if I switch them over to static lights and rebuild, they just disappear. Any remaining lights that were stationary, still show up in the new build. They are point lights with no special functions or anything. They are casting light onto static meshes with proper lightmap UVs. Indeed, it all shows up fine in stationary mode but forget’s it’s there when I switch them to static. Am I missing something?

Thank you!

Hey kta3d -

Could you post a screenshot of the error, it would help us eliminate a few possible problems right off the bat? With what you are describing though I would check to see if your meshes are set to movable? Movable meshes do not take Static lighting.

In any event, let me know and we can work out the problem -

Eric Ketchum

Hey kta3d -

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

Eric Ketchum

Hello very sorry for the delay!!!
I was having the issue at work but got put on another project so I’ve installed the editor at home to test it. I had a little project going and had a mesh with some textures and materials but suddenly the editor wont even open my project anymore. It hangs forever on “compiling shaders: WorldGridMaterial.” Once I got it to open after a long wait but the “compiling shaders” message stayed in the corner of the screen for hours until I just gave up. None of my materials showed up in that time.

It just started doing this one day and, even after upgrading to 4.4, I still have the same issue. A new project will load but my old project just hangs. There are 3 “ShaderCmpileWorker” processes in my task manager as this is happening

I’m using the 64 bit version of the 4.4 editor. Setting it to start as administrator (by browsing to the .exe and setting it to always run as admin) appears to break the launcher but it can still be run from clicking on the .exe. Even then, same issue.

I have 16gigs of ram and a 6-core AMD FX proc @ 3.8ghz and a GeForce GTX 660 w/ 2gigs. Running Win7x64. I have Avast! antivirus and an ikea refrigerator.

Hey kta3d -

In the project that is causing you problems, try deleting the \Unreal Projects[Project]\Intermediate directory. This will eliminate any cached shader compiles that might have errors in them.

Let me know -

Eric Ketchum

I had previously just left for a few hours to let the thing compile and it did eventually start working as expected. I tried deleting the intermediate directory as well and that seems to have stopped it. Thank you!