Why do my meshes look like this?

So, I model in Blender…I mark my seams and unwrap with no overlapping islands - the UV map is a confusing mess, still, but nothing is overlapping and its still somewhat coherent. I didn’t smooth the faces in Blender because it looks like ■■■■ when I do that (Worse even than when I. Gives me the “smoothing groups” error upon importing - I go into the asset and recalculate the normals. Rebuild the lighting - the end result is hideous. To be quite honest, I’ve been using Unreal for only a few days longer than a week and blender for only a month. I am as green as green gets. Also, after I rebuild the lighting then test the map, the in-game resolution is magically transformed into something that looks like Quake 1 being played on a period machine at the lowest settings.

Hello Half-Rats,

One of the more important things about creating your ‘Static Meshes’ is making sure the UVs are cleanly unwrapped and taking up as much of the 0 to 1 UV space as possible. This allows you to maximize the efficiency when setting the overall resolution of your Lightmaps.

Your image seems to have some ‘Aliasing’ along the edges of your buildings. The ‘Anti-Aliasing’ setting can be improved or turned on via the ‘Engine Scalability Settings’ within the ‘Settings’ drop-down menu of your main viewport. Here is a reference image on how to find where these settings are located.

Engine Scalability Settings

The next issue I am seeing in your image, and probably the question you are asking, is the ‘Lightmap Resolution’ of your ‘Static Meshes’ seem to be too small. In order to edit this, along with many other settings that can help improve the rendering of your building, you need to double-click your mesh inside of the ‘Content Browser.’ This will open up the ‘Static Mesh Editor’ window.

Here you can edit things like the ‘Lightmap Resolution’, the ‘Lightmap Coordinate Index’, and to 'Generate Lightmap UVs…etc. Here is an image that will show you how I have set up a fairly simple piece of geometry so it bakes an accurate ‘Lightmap’ and is cleanly rendered.

Pool Static Mesh Settings

Notice how the faces/polys of my object are evenly spaced throughout my UV space so I am able to get an accurate and cleanly rendered model. Here is some helpful documentation about Lightmaps that will give you a more in depth answer.

Unwrapping and Lightmap Documentation

I hope this helps clarify a bit, but if you are not getting the results you are looking for let me know and we can explore some different options.

Cheers,

Andrew Hurley

Oh, thank you for the response. I believe I’ll try that out. Also, I couln’t upload it at the time, but here is the picture of the mesh unwrapped in blender.

Also, I must say, it didn’t show any of the UV channels in Unreal Editor when I click on the mesh asset! Ahahaha. Must be doing something wrong. Why are there two UV channels in Unreal? (UV 0, UV 1)

There are two channels, one for your normal UV map and the second is for the light map - having shadows cast on your mesh.

In a normal UV map, you can have overlapping areas if you want those areas to be painted identically (or mirrored/flipped). If you weren’t aware, you also want to scale up areas that require more texture detail and shrink down the places that don’t. It doesn’t always have to match how big the area is in the mesh.

Now UVs for light maps can not only never overlap, but they need a few pixels of padding around each island. Also for this UV map, you probably want to have the scale of each area closer match the scale of that part of the mesh to make sure the shadows looks nice everywhere.

So in Blender you need to either make two UV maps, or let UE create the second UV light map for you on import. Some people don’t trust it to do a very good job, and make it in Blender themselves.

^ What he said!

Essentially one UV map for your texture and material detail, and the other for your Light Map.

In order to view your UV’s you just need to select the ‘UV’ button at the top-most bar shown here:

Cheers,

Andrew Hurley

Thank you both!

I’m assuming it looks much better, yeah?!

Glad to have helped!

Let us know if you need further help.

Cheers,

Andrew H

That it does! I am getting an “Orange” reflection on faces that are overhead of the player character, however. Is this normal?

Glad to see it looks cleaner!

This coloration on your Static Mesh could be due to a few things. This could be your material that you have applied to the building, your world’s scene color, or a setting within your ‘Post Processing.’

To see which of these is causing your issue, do me a favor and enter this command into your console within the editor “ShowFlag.PostProcessing 0.”
This command will effectively disable the Post Processing within your scene and you will be able to see if your issue is caused by these settings. In order to turn it back on, just replace the 0 with a 1 using the same command.

To bring up your console within the editor just press the tilde or (~) button.

Also would you provide me with a screenshot of the material set up you are using for the mesh?

Cheers,

Andrew Hurley

Fixed it! Thanks - Had to do with the fact that this mesh had no 'back" and light was pouring through in places it shouldn’t. Now, more hurdles lay in my way, haha! Texturing and scaling properly - materials facing the wrong way and stretching on my meshes. But that’s for another time. Going to have to learn to build piece by piece and uniformly scale the meshes in blender better. Should have went about building this store in a different manner.

That is the best part about learning!

You have to make mistakes in order to learn the proper way sometimes!

Again, let us know if you have any more questions and we will be happy to assist you.

Cheers,

Andrew Hurley

Don’t tempt me, haha - I’m trying to go as long as possible without running back to answer hub and bothering everyone :slight_smile: But I must say I love the willingness to help on the part of the community and staff - Epic has a very solid operation here. I hope to become proficient enough in the engine to be able to help others some day.

‘The one who resists to ask why, will never learn’

We encourage our users to troubleshoot issues themselves, but also to ask questions. The only way to become better is to keep challenging yourself!

We are here to help everyone, from the beginners to the professionals. I would say the best place to start is to find what you enjoy within the scope of video game design, and become proficient enough to where it begins to touch on other areas of knowledge. If your interest is sparked there, it will continue to lead you down a tunnel of exponential possibilities!

With that said, Goodluck! Let us know if you have any questions :slight_smile:

Cheers,

Andrew Hurley