Why are my movable meshes different shades?

Hey all,

I’ve had this problem a few times and still can’t seem to work out a way around it without disabling cast shadows altogether. It usually happens when I have two doors side-by-side in a scene, such as a fridge or wardrobe doors.

This is what I want it to look like (mobility: static):

And this is what I get when I change the mobility to movable and bake the lighting:

Any suggestions would be much appreciated.

This is a good starting point with movable actors in statically lit environments: Indirect Lighting Cache in Unreal Engine | Unreal Engine 5.1 Documentation

Visualizing the volume sample placement and seeing if the top mesh is out of range of the placed sample that is lighting the one below would be a good place to start. You can quickly check this by taking the door and moving it down closer to the floor like the bottom door and see if the lighting is similar between the two then. If so, you’ll want to adjust the height or number of samples that is placed. This may have to be done in the BaseLightmass.ini file to get the best results, but you should be able to get it in the editor without having to touch the ini file.


Thanks, Tim. Where would I adjust the height/number of samples in either the editor or the .ini?

I managed to find both the in-editor settings and then relevant .ini settings under [DevOptions.PrecomputedDynamicObjectLighting], but after about half an hour of trying a number of different height, spacing and sample layer settings I’ve made no progress. Am I missing something?

You’d want to adjust in the ini NumSurfaceSamplesLayers. The default is two. The first sample is always placed at 50 cm above any surface and the next at 300 cm (or 250 cm above the first sample).

After you change these, you will need to rebuild lighting for them to take effect.