Why am I getting Error 2738 when trying to install Unreal Engine 4?

I signed up for the subscription for Unreal Engine 4, but when I went to install it, an error message came up with the error code 2738 and cancelled the installation. Could really use help, thank you!

1962-error.jpg

Hey Decyphur,

Have you tried redownloading the Launcher? What are your machine specs / OS?

I’m getting the same exact error. I’ve downloaded the installer a second time, but that didn’t help.

My machine specs:
Windows 7 SP1 (64-bit)
Intel Core i5-2450M @ 2,5 GHz
8GB RAM

I’ve installing from my Downloads folder, from the desktop and from a flash drive. Same issue. Here’s the log file generated by adding /L*V UnrealEngineInstallerLog.txt when executing the installer.link text

Thank you for providing the log, it was very helpful in finding the issue. The installer relies on VBScript which your computer is having difficulty accessing according to this line from your log: “DEBUG: Error 2738: Could not access VBScript runtime for custom action”

This means that it is probably not registered with Windows for some reason.

This might work for you:

  • Microsoft Utility that will try to fix the issue: Link

You could manually try to register the VBScript dll files:

  • Make sure you have vbscript.dll in the following folders:

    %windir%\system32 (This is usually C:\windows\system32)

    %windir%\syswow64 (This is usually C:\windows\syswow64)

  • Run cmd.exe with admin privileges. To do this, start a command prompt as Administrator (Start → type ‘cmd’ in the search box and then right click on cmd.exe and select Run as Administrator. Click continue when prompted by the User Account Control dialog.). Once you do this you should have a command prompt open in C:\windows\system32 (or something similar depending on where windows is installed but you want to be in the folder that regsvr32.exe is located in)

  • Unregister vbscript by running these two commands one at a time in the command prompt. You should see a confirmation after each run saying vbscript was unregistered.

    regsvr32 /U %windir%\system32\vbscript.dll

    regsvr32 /U %windir%\syswow64\vbscript.dll

  • Register vbscript by running these two commands one at a time. You should see confirmation after each run saying vbscript was successfully registered. NOTE: If you need to re-register vbscript.dll, be sure to run these in an elevated console on Windows Vista and newer with UAC enabled; otherwise, you’ll end up registering the runtimes in HKCU and you don’t want that.

    regsvr32 %windir%\system32\vbscript.dll

    regsvr32 %windir%\syswow64\vbscript.dll

  • Run the installer again. It should work now, if not you may need to restart your computer.

Another potential solution:

  • There are some additional steps outlined in the following thread: Link. Using the info from this thread, MaverickNico was able to find the reason he was seeing this issue.

MaverickNico:

“That thread actually helped. I was able to run the installer after uninstalling Macafee.”

Thanks for the quick response! I tried the steps above with the same result, unfortunately. I’ll try it again, generate the log file and upload it again.

Thanks again!
Nick

Sorry the solution above didn’t work for you. It may be that it is not complete. Looking at it now, I probably should have had you unregister first(just to be on the safe side) before running the register step. I probably also should have included the x64 version too. I’ll update the steps to be more clear and more complete. Any additional logs you provide would be
great!

I am getting this error message when trying to run the installer for the unreal engine:

“The installer has encountered an unexpected error installing this package. This may indicate a problem with this package.

The error code is 2738.”

I have tried redownloading the installation files from unreal website. I have also tried this:

I have tried runnining the installer from the desktop.
I have also tried installing the updates for windows on my computer.

Here are my computer specs:

Intel(R) CoreT™ i7-3610QM CPU @2.30Hz

RAM 8.00

64 bit

Windows 7

Service Pack 1

Please advise as to what I should do to be able install Unreal.

My dxdiag file:

link text

Just to confirm, you tried registering both x86 and x64 vbscript.dll files? It would help to get your installer log. You can get this log by doing the following:

  1. Place the msi on the root of C drive

  2. Start a cmd prompt as administrator (Start-> type cmd in the search bar and right click cmd.exe and select Run as Administrator)

  3. You should see a command prompt that says Administrator in the title bar

  4. Enter the following command(be sure to replace ‘UnrealEngineInstaller.msi’ with the actual msi file name):

    msiexec /i C:\UnrealEngineInstaller.msi /L*V C:\UnrealEngineInstallerLog.txt

I have tried registering the x64. How do I register the x86?

In the instructions above, you should see two individual commands under each step. Ex.

x86:

regsvr32 %windir%\system32\vbscript.dll

x64:

regsvr32 %windir%\syswow64\vbscript.dll

Yes, I tried registering x64 and x86. I unregistered and registered them as the instructions gave before.

Here is the log file it generates for the installer log:

link text

It looks like the installer was not launched properly in the log you provided so the log file wont help in this case. If you used the steps I posted for generating that log you might want to try it again with the edits I made to the steps. I had to make edits to my post for those users that do not have permissions to write files to the root of the drive.

Can you show me what you are referring to when you say

If you used the steps I posted for
generating that log you might want to
try it again with the edits I made to
the steps.

Sure. I’ll just post it again. To get an installer log file you can do the following:

  1. Place the msi on the root of C drive

  2. Start a cmd prompt as administrator (Start-> type cmd in the search bar and right click cmd.exe and select Run as Administrator)

  3. You should see a command prompt that says Administrator in the title bar

  4. Enter the following command(be sure to replace ‘UnrealEngineInstaller.msi’ with the actual msi file name):

    msiexec /i C:\UnrealEngineInstaller.msi /L*V C:\UnrealEngineInstallerLog.txt

I did that and here is the log I receive:
link text

That log that you got is msiexec telling us that the command used to start the launcher was not correct. In other words, the launcher didn’t actually start. We’ll need to figure out which part of my instructions is having the issue.

Can you tell me what the installer is named on your computer?
Can you copy/paste the exact command you used?

I’ve followed the instructions above to unregister and then re-register both DLLs, but the installer is still failing with the same error message.

I’ve attached the latest log.link text

I searched the registry and only found vbscript under the HKEY_LOCAL_MACHINE hive. I went ahead and ran the utility anyway. Unfortunately, I’m still seeing the same error as before.

BTW, I really appreciate the quick response!