White unlit not white?

I have been trying to figure out my problem for ages, but have had no success.

In my simple game almost all objects have a completely white, unlit material applied to them, however they are rendered with a grey colour instead?

I have checked everything I can think of; Post process settings, material instance settings, and the player’s camera itself, and changing any of these things doesn’t change anything, it still becomes grey?

Hey WarLord -

Try increasing the value of your inputted vector 3 color and set them to over 1,1,1 to 1.5,1.5,1.5 or even 2,2,2. You will want to manage the increase in whiteness and the brightness aspect.

Thank You

Eric Ketchum

Yes, I have tried this before, however due to the fact that it is unlit and so uses emissive, the excessive colour creates bloom.
PS. Even in the material editor the material is not white.

Hey WarLord -

I was able to reproduce this issue and have reported it to our engineers for further investigation, TTP # 348166. I will keep you informed as we investigate this issue.

Thank you

Eric Ketchum

Thankyou :slight_smile:

Was Any kind of solution for this problem reached? I have a similar problem.

Hello -

This issue is actually not a bug but a function of the post process and physically based rendering. The final color will depend on exposure, the other lighting in the scene, etc. 1,1,1 doesn’t mean that’s the final tonemapped value on screen. That is the intensity of the light being emitted by the surface.

Thank You

Eric Ketchum

Any update?

As I said at the time (the issue still persists) the cause is not exposure, lighting (unlit anyway) or post processing - this doesnt answer the question of how to make unlit materials proper white without the bloom setting values higher than 1,1,1,1 gives - please stop accepting the answer for me - I will accept an answer when it answers and solves the issue, thanks.


Hi. If you don’t need it, you could try to disable the tonemapper. That way you would get the colors exactly as you intend them to be. You can see a discussion about it here: Struggle Against Tonemapper

I have this issue too. The link provided by PacoChan solved it.

Create a post process material to replace the Tonemapper.

Then added it to the PostProcessVolume in your Level. You will have the exact color from the unlit materials.

1 Like

This is still not fixed??

Under Film in the Post Process Settings is a setting that is called White Clip, setting it to 2 makes whites white that have regular lit shading with emissive. It however does not fix the issue with Unlit materials. Unlit white is always very greyish. Using 4.21 here.

The answers above helped me a lot, so I will share my improved solution.


Create a Material:
Material Domain “Post Process”
Blendable Location “Replacing the Tonemapper”

From now it depends what you want. If you have a Material which is unlit and only using emmissive color, lets say RGBA = 1,1,1,1 (white). And if you want exactly this, add in Post Process Material “SceneTexture:PostProcessInput0” and connect color to emissive color, done!


The math above is used for Gamma Correction, the example image above is sRGB Gamma Correction. If you insert RGB but want sRGB you can apply Gamma Correction like @riverprawn posted. I have done this for every channel because there is a case missing.

And the reverse would be, your unlit material emmisive color is sRGB and you want RGB:

The Gamma Correction is sRGB but maybe you want another. This is a good source:

I know this thread is very old, but for anyone searching solution.

Set Post Process Film properties:
Slope = 1
Toe = 1
Shoulder = 1
Black Clip = 0 (or doesn’t matter)
White Clip = 1

You can get true white (1, 1, 1) without replacing tonemapper (if you didn’t set other color factors like white balance or tint things.). And, of course, it changes entire scene color and mood.

Camera-> Exposure-> Advanced-> Low Percent-> 100