Announcement

Collapse
No announcement yet.

Struggle Against Tonemapper

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Struggle Against Tonemapper

    Let me get this straight, is there any friggin' way to disable the Tonemapper?
    I tried just about everything
    I asked in previous threads like this one:

    https://forums.unrealengine.com/show...-how-to-fix-it

    And got no answer on how to replace it.

    So please, pretty please, with sugar on top, who do I have to beg at Epic Games, to implement a checkbox in Post Process Volume, or something like that, which was promised years ago.
    Is it really that difficult?
    You can get sooooo close to the look that is unaffected by the Tonemapper by tweaking a Post Process Volume:

    TM ON
    http://s15.postimg.org/yos5orocr/TMON.jpg
    TM OFF
    http://s23.postimg.org/sajjpyh17/TMOFF.jpg

    But can you disable it completely? Nope! Not in game, only in editor window for some unreason.

    #2
    I've been struggling with this problem too for some time now. I've tried everything but I can't get my colors right. Epic should atleast give us the ablility to adjust the tonemapper settings like Unity does.

    Comment


      #3
      Make postprocess material. Then set "replace tonemapper" done.

      Comment


        #4
        Originally posted by Jenny Gore View Post
        Make postprocess material. Then set "replace tonemapper" done.
        I've asked you in the other thread (link in the original post) which steps do I need to take to make it work, and got no answer.
        Maybe I'm doing something wrong, here's what I've done again:
        I set up a new material, set it to Replace the Tonemapper, Create a Post Process Volume, Assign previously created material to Blendables, tried to fool around with the material, but it didn't cancel out the original Tonemapper

        Comment


          #5
          Click image for larger version

Name:	Tonemapper.jpg
Views:	1
Size:	295.2 KB
ID:	1099776

          Just tested this. This simple material overrides tonemapper. Exposure settings don't work anymore. Bright spots are all clipped to white.

          Comment


            #6
            Thank you for answering, so I guess just replacing the Tonemapper with something won't magically fix everything)
            Is there any way to make it work?
            I'm just really trying to help not only me, but everyone else who hates this feature, which at best limits precise control of colors, and at worst makes everything made in UE look the same.
            It's the UE way or the highway, which sucks a lot.
            I won't use Eye Adaptation, I don't need the engine to map my values into a LDR, can't I just see the normal image without this bs!?
            Last edited by SimplyMark; 02-03-2016, 01:58 PM.

            Comment


              #7
              So, just to recap, I'll use the default map as an example:
              Tonemapper (Why is this default?)

              No Tonemapper (What I want)

              As close as you can get to No Tonemapper by tweaking a Post Process Volume

              And the solution I was proposed above, unless I got something wrong again

              Calling out for any help...
              Last edited by SimplyMark; 02-03-2016, 03:46 PM.

              Comment


                #8
                It seems that you have to do linear to sRGB conversion in your post process material too. Just try with sqrt(color). If that looks aboutright you can do more precise linear -> sRGB conversion. http://chilliant.blogspot.fi/2012/08...-for-hlsl.html

                Edit: You should look there what all tonemapper does. https://github.com/EpicGames/UnrealE...essTonemap.usf

                It's also do film grain and much more.
                Last edited by Kalle-H; 02-03-2016, 05:25 PM.

                Comment


                  #9
                  Originally posted by Jenny Gore View Post
                  It seems that you have to do linear to sRGB conversion in your post process material too. Just try with sqrt(color). If that looks aboutright you can do more precise linear -> sRGB conversion. http://chilliant.blogspot.fi/2012/08...-for-hlsl.html

                  Edit: You should look there what all tonemapper does. https://github.com/EpicGames/UnrealE...essTonemap.usf

                  It's also do film grain and much more.
                  You are correct, it does much more, that's why disabling it would not be the best solution.
                  And I had a feeling that doing that conversion is exactly what needs to be done.
                  The problem is that I'm only a concept artist trying to put my ideas in 3d, so I lack the knowledge and skill necessary to perform something so complex to me.
                  And it seems so weird that we have to do this reverse engineering, when it should be the default option and what we got as a default right now should be an extra feature.
                  If anyone here cares and understands how to do it, please give it a shot, you would help out so many of us.

                  Comment


                    #10
                    UE4 use physical based rendering as default. This mean that HDR has to be default which mean we need tonemap by default.

                    Comment


                      #11
                      Originally posted by Jenny Gore View Post
                      UE4 use physical based rendering as default. This mean that HDR has to be default which mean we need tonemap by default.
                      I'm sorry, but from everything I've read it seems that all of those 3 concepts can exist without the other, if I understand correctly.
                      Tonemapper is only useful when you have HDR, but you can have Physically Based Rendering without HDR, which is what I want, so the Tonemapper becomes obsolete, yet you can't turn it off.
                      Would definitely like a second opinion on this though.

                      Comment


                        #12
                        Originally posted by SimplyMark View Post
                        I'm sorry, but from everything I've read it seems that all of those 3 concepts can exist without the other, if I understand correctly.
                        Tonemapper is only useful when you have HDR, but you can have Physically Based Rendering without HDR, which is what I want, so the Tonemapper becomes obsolete, yet you can't turn it off.
                        Would definitely like a second opinion on this though.
                        You can't have physical based rendering without HDR. Most specular highlights would just cap to white.

                        Comment


                          #13
                          As Jenny Gore said, you can replace the tonemapper with a post-process material. But as you saw, it looks darker if you do it. You can try a gamma conversion like this:



                          Tell me if that is ok for you.

                          Greetings!

                          Comment


                            #14
                            Yes, thank you very much, I really appreciate the effort, that disables the tonemapper just fine)

                            Comment


                              #15
                              I want to thank the people in this post!
                              The reason I do some grave digging here is because this was the only solution to make my pixel art game look normal.
                              It took me a long time to find it. Either people are not using unreal engine to make pixel art games or people dont notice their pixel art looks wrong.

                              I first tried the console command "ShowFlag.Tonemapper 0" This worked fine, untill I build my game... in the build the tonemapper is back and messes up my pixel art.
                              I also tried manually changing the post process settings to recreate the look I should have. But you can never get it just right, and it is messy in any case.

                              This worked, even though I know the sRGB conversion posted by Pacochan is not perfect, it is pretty close.

                              I wonder why there is no simpler solution, even now in 4.18.

                              Comment

                              Working...
                              X