What's up with splinemeshes not generating shadows?

I followed this guy’s tutorial:

Unreal Engine 4 Road Tool in Blueprints with Spline and SplineMesh - Part 1 Spline Components - YouTube - the fourth in the series.

And the splinemesh itself works great, but the material on the other hand, seems to not cast shadows at all. I applied to material to the same plane separately as a staticmesh, and that cast shadows fine, creating the simalcrum of water caustics without extra effort (I activated a few shadowing options for dynamic translucency). But the same material applied to the same plane only set as a splinemesh refuses to cast shadows. The splinemesh generator has the exact same settings with regards to lighting and everything else but refuses to interact properly with the lighting in the level.

Is this a limitation of the splinemesh feature? Or am I missing something?

Hi Mugluck,

Could you post some screenshots showing the material issue in action?

As you can see, the plane closest to the camera is casting shadows, the splinemesh (currently selected with blueprint on the right) is not. In fact it’s not casting anything.The water is tiled according to a global position, so they both tile exactly the same.

To help us test the issue, could you provide the material and textures that you are using? If you don’t want to post them here you can private message me directly on the forums.


Yeah that’s fine. I’m working on a much better water material, having figured out a few extra functions, I keep this for debugging reasons. The attachment is telling me it’s not the right format, so here’s the dropbox link:

Since the material works fine on other assets, I’m not sure it’s a material issue, and specifically a splinemesh issue, as the spline objects still cast shadows fine.

The material you uploaded doesn’t cast shadows while applied to a static mesh or a spline. Are you doing anything special with the lighting to get the translucent material to cast shadows correctly?

Yes. You need to turn on volumentric translucent shadowing in the advanced lighting. I’m also using fully dynamic GI which has been properly set up and works fine. It’s helped a lot with editing speed.

Note: I’ve made sure the splinemesh options are the same. They don’t seem to change anything.

Hi Mugluck,

Try removing the Fresnel node from the Opacity channel of your material.

Although it doesn’t seem to be causing this issue, make sure you keep in mind that Dynamic GI is still considered experimental and may give you unintended results.

Ok Problem solved. As I thought, it had nothing to do with the material and everything to do with the Splinemesh/Lighting.

The splinemesh will only generate shadows if the material AND mesh are referenced in the splinemesh properties. See attached image.

After that, it depends on what your material settings are. It doesn’t seem to make a difference as to whether you use baked lighting or not, or whether the splinemesh is static or moveable. What does make a difference is how your material’s translucency and opacity settings are set up. Without the material call in the splinemesh properties, it ignores all lighting except surface shaders by the looks of things.

Hope that helps everyone.

Yeah, that’s why I popped this in bug reports, I figured it was a pretty isolated instance and you guys might want to be informed.