Download

What is causing this and how can I fix it?

I have these weird designs on my imported heightmap. I know I can use “smooth” to get rid of them, but if there is a better solution, or if someone might suggest a reason for them being there, I would appreciate it.

Thanks!

What are the parameters of the heightmap? Did you use RBGA8 or 16? It appears to be artifacting due to the engine not scaling and extrapolating the data correctly. You need to provide more information on how you made the heightmap and how it was imported to Unreal though.

Sorry… I guess it would help to know that… ::Humble grin::

I created the heightmap in PS3. It’s a 16-bit greyscale .raw image. It’s dimensions are 4033x4033. I didn’t see any options - other than the settings in the editor - for importing it.

When I save the .raw file from the .psd file, I set it to header: 0 and IBM PC.

I have: sections at 4(2x2), component size 126x126 with total components being 1024 (32x32) - as recommended by this tutorial:

There are a few areas where it also looks like a “tear” in the landscape but up close it’s just a small one square “ridge” that runs a long distance and can be smoothed over as well. I’m guessing those are areas where I did something wrong when creating the map. Like, cloning something to another spot or something and it not quite blending correctly. You can see that in the image I uploaded, too, in the upper left corner.

It’s just that odd patch - only in that one spot - that I can’t seem to figure out.

Thanks for the reply!

Did you apply a blur to the heightmap before importing it to UE? It appears the pixels of the pre-imported heightmap are showing in the entire landscape inside Unreal. I noticed the upper left problem area before you pointed it out in the last post, but I’m not sure if it’s an issue with the heightmap itself because there’s a problem in Unreal where if you’re using stationary lighting, black lines will render across the landscape on the component grid. So, for your 32 x 32 components grid, there’d be 33 by 33 grid lines that are that dark and that thick across the entire landscape if that’s what the issue is…there’s a fix for it which doesn’t require turning off stationary lighting completely. You simply switch to movable lighting and back to stationary, I think, though there might be one more part to the fix.

If that’s not it, I’m thinking you probably didn’t smooth the area with a tool in photoshop and/or blur it out after cloning a piece to attach it to that part of the heightmap. So, there’s a borderline there that the engine rendered from the edge area of the patch in the heightmap.

Another thought I had was your X and Y, and possibly Z, values for the landscape are too high, resulting in the visible squares / pixelated look. Instead of 100 (1 meter) per quad, which in a 2x2 section land, the quads are multiplied by 2 per axis. So, in one axis (x or y), with 128 quads per section…2 sections (256)…32 components (256 x 32 = 8,192)…you have 8,192 meters approximate distance from one edge of the map to the other. That’s about 8 km. Was your original heightmap that long and wide? If it wasn’t, then you need to scale things down either in the original, or in Unreal, or possibly both to get more exacting proportions. You’ll probably need to do a few calculations. Here’s another tutorial on how to acquire a real-world heightmap and adjust it in Photoshop for import to Unreal. A couple other important settings are what greyscale mode / type in Photoshop or other external software you use, and the DPI, which in the video I’m linking below is set to 72 DPI.

It could be the primary reason or basis of all your problems so far, that the heightmap is not properly prepped for Unreal import and the settings in Unreal are incorrect. But the cloning and moving of the one patch, which is obvious in Unreal, and the tire tracks artefacting in the central-right part of the landscape could easily be due to other causes yet unknown. However, it’s probably the patch wasn’t accounted for enough in Photoshop for Unreal to produce an accurate result, if it’s not the stationary light issue I referenced. Link:

The problem is that OP is trying to use photoshop (.psd is really only a photoshop file as far as I know).

Photopshop does not support 16bit.

Work on the files in a program that supports 16bit - Krita, and probably Gimp.

I blurred it a little, but too much made the entire thing too smooth in the editor and I lost all those nice erosion lines. The dark lines, like the one in the upper left, /are/ from the cloning I did. I went over the image, zoomed way in, and found those spots in the image and blurred them to remove them and it helped.

But, I couldn’t find that weird spot in the image anywhere, so couldn’t fix it pre-import.

I know about the dark grid lines and turn off static lighting to fix that… :slight_smile:

The image is 4033x4033 and that’s the size the editor set when I was ready to import it.

The image is set to greyscale, 16-bit and 72dpi in Photoshop.

I’ll try to locate that exact area in the editor then try, again, to find it in PS. It’s not a major point, just annoying to have to try to smooth it out without messing up the landscape too much and losing nicer details in the map.

I really appreciate the replies. If I can’t find it in the original image, I’ll just have to smooth it out in the editor and hope for the best. :slight_smile:

Just thought someone may have seen it in their work, too, and know what causes it.

You can change the size post-import from 4033 x 4033. It sounds as though the scale of X and Y needed to be reduced, which would mean having to reduce the Z scale to get correct proportions. If you were to go in Photoshop, zoom in on the spots that need correction / repair, and blur…it’s going to result in a stronger result unless you do an extremely small amount / strength of blurring. You could also try disabling the 2x2 sections in Unreal, and compensate if necessary by doubling the components OR doubling number of quads per component. However, if you double quads, then it’s going to add stretching distortion unless you reduce the XYZ scale values. Doubling number of components would make the landscape bigger, so you would need to fill in the empty space if there is any…and/or you would need to change the XYZ scale values to bring it to the right proportions.

There’s no way I know of to simply edit out the bad result of the one area before importing it to Unreal other than blur and maybe a blend of some sort. You could attempt to use a simple brush to add in a new set of height data, perhaps that’s similar to the surroundings…or maybe create ditch or a cliff or something else. At least it would remove the artefact / weird lines. If it doesn’t remove those, then something is likely wrong during import in Unreal or something more odd is happening with it in Photoshop.

Maybe I wasn’t clear:

This doesn’t mean anything at all in photoshop. Photoshop cannot work in 16bit.
All your 16bit file(s) are automatically transformed into trash the moment you open and save them from photoshop.

If you want to get rid of artifacts, use any program that natively supports 16Bit files.

@presto423
Btw, what you suggest wouldn’t really work.
When you import a PNG as the landscape the image is used as is and placed inside whatever component size you select.
It won’t stretch or alter your PNG file to fit - it will simply have a flat (65535/2) area around the image you selected.

@op.
The proper way to work the file is to use a radial blur value matching a radius double the size of what you stretch.

In your example, if the file needs to be doubled up, then you would run a radial blur with a pixel radius size of 4px to blend the area so that you get no evident terracing.

@MostHost_LA

Trust me. I’m not questioning your expertise at all! Just confused.
So, even though PS3 offers the option to create my image in 16-bit format, it doesn’t really save it that way, despite saying it is?
If that’s the case, I guess I’ll look into Gimp or something else. I can’t afford to purchase another art program, so anything like Gimp that’s free will have to do.
Also, when you said I would need to “double up” the file, did you mean to make the image twice the size, blur those areas, then reduce it back to 4033x4033?
Thanks!

It may save it “that way” but the values aren’t png16.
They are actually changed somwere between 0 and 255, and 8bit, or 15bit plus one… and then they are converted to a 16bit equivalent.
That means the colors aren’t the same the moment photoshop opens the file.

KRITA should still be free, and open source, and it does support 16bit native.
It’s hard to use / won’t have the same functions as photoshop, but to make changes and keep the file correct it works great.

The way you approach the stretching is just related to what you need.
You definitely get cleaner results when you double up, but you may not be able too.

The radial blur value is always just double the stretch in px. By excess because it needs to cover the actually distorted places.
Not all software let’s you choose a radius when doing radial blur…

I think Nip2 does - but it’s basically command line with a simple gui. Maybe you can find a gimp or a Krita plugin to do the same process with mathematical values. If not, you can probably just eyeball the result.
The goal is to make the terracing you generate when stretching less visible…

The X and Y scale of the landscape in Unreal can distort or stretch / compress the initial imported PNG based on the component and quad values.

@Cilmesse
There’s a program called Inkscape which is open source that may be capable of doing what you need. I think it supports 16bit too.

The x/y scale should never be touched unless you know what you are doing.
It alters the position of the vertex, so you would no longer have a vert of landscape each meter.