What is causing lighting to not show up on the Samsung Galaxy S6 with Gear VR?

I have reduced the size of the textures and made sure they were not over 512*512. Tiling is off for all of the textures. However, the lighting will still not appear with the Gear VR. The objects still appear on the screen, but you can’t see them due to the non-functioning lighting.

I tried to migrate the project to 4.10, but with not much effect.

When troubleshooting lighting there are many variables to check. You can attempt to go through each thing one by one or you can start from ground zero and work back up to where you are now to see which element breaks it.
First of all did you ever have functional lights? Do they function in the editor but not the gear vr? If they work in the editor but not the gear vr then my guess is it’s a baking issue. Lightmaps aren’t beingcreated or they aren’t being stored or else it’s a technical limitation in which the gear vr doesn’t support them. Trying testing a small scene with just one light. Try a point light. Try it as dynamic then try it as static. Do the same for each light type and make sure to build out each one and test it on the gear vr. My guess is that you will discover what is wrong during this testing and if you don’t then there is another issue more specific tp your scene or the camera setup of your scene.