Download

What about Reflections on a Translucent Material?

Well, im bout to create water.

Problem is… Reflection stopped working immediately after setting material on Translucent Blend Mode.

Is there a way to recreate the reflections?

If you’re in 4.8 have you tried enabling “Screen Space Reflections” in the material attributes under the Translucency tab?

Its on already. :c

Retested: After i changed the blend mode to surface… reflections are back.
But i want opacity nodes for shorelines etc.

:expressionless:

Set Blend Mode back to Translucent and then set Translucency Lighting Mode to TLM_Surface.

Already done too. Its hard to believe… :c That doesnt makes sense.

Can you confirm you have the four settings I have checked off in this image set correctly? This setup works perfectly for me.

Translucency.PNG

Also how is your lighting set up?

EDIT: Just noticed I ticked off “Responsive AA”… This is not needed for translucency, just ignore it for now. :slight_smile:

Also note that TLM_Surface was renamed to “Surface Translucency Volume” in ver 4.8. If you are using an older version, there will be no SSR for translucency available.
If using an older version, you can add some specular highlighting using a “SkyLight” actor in your level.

Yes they are on!
Placing a skylight actor works… but the reflections looking very bad. Very very bad.

The normal ones without translucency even work without light and looking great… O.o what is that sorcery!

Hmm… Just to confirm, you are previewing the material in your scene correct? The Material Preview in the top left corner of the material editor is not going to give you an accurate representation of how it looks in engine, so make sure to apply this to an object in your scene.

How about the values you have set for the surface such as your Roughness value? Are you using Refraction? Is this just a basic material set to Translucent?

Also double check your level lighting to make sure it is either set to Stationary or Movable, I remember reading another post that mentioned Translucent SSR doesn’t work with static lighting.

Could you also please let us know which engine version you are using, and whether you build from source code or download the engine through the launcher?

Ok:

Version 4.8.3
Light ist moveable

Roughness 0.01
Metalic 0
Spec 1

Refractions on
Material is translucent
SSR on

Ingame View: Always!

Im also companied by a friend of mine who has working water… but his is very specific and none of my business.

You can bump up the Specular value to 10 or even 30 for translucent materials, and increase Metallic as well(0.3-0.5)

This changed only one thing. It just gets darker :c

Well at this point it would benefit us all if you could share some screenshots i think. :stuck_out_tongue:

I think i attached the screen. :3
Well i worked on this the last 7 Hours now… and i tried everything. This is a shader that is in the industry since 2005 and ue cant handle it XD

bricks_1.PNG

Could you possibly take a screenshot showing the material in game? We’ll be able to see whether the SSR is actually working or not. If it’s not there might be a setting turned off somewhere, or possibly something wrong with your UE4 installation (because this “just works” normally).

One more thing I would mention is that you need to have the editor viewport in “Real-Time” mode to see the SSR translucency. I like to work with it off sometimes to lower my GPU usage, and turning real time off does make the SSR darker for my ocean material.

I dont know if it is usefull but:

http://blueprintue.com/view/uj_Cu-Bw/

I will take the screenshot ingame in meanwhile!

Took the screenshot:

ingamewater.jpg

Might have done the impossible…

By adding a extrem bright skylight i somehow triggered the reflections…
They are HERE!

But they are weak and i have to do some medicne work for em :,3

I don’t see any SSR there at all, the water isn’t even shiny from what I can tell.

Can you try creating a new material that is Translucent, SSR enabled, and set to “Surface Translucency Volume” (like the image I posted earlier), then set the opacity to something like 0.3 with a blue-ish default color and apply that to a box (or plane) in your scene to see if the SSR works at all? This will rule out whether it is an issue with that specific material, or an issue with your engine.

From the image it looks like you have set up a PP volume with some custom settings, are you using any blendable materials that might be filtering other materials in the scene?

For reference, this is how my water material looks with SSR enabled:
Reflect.PNG

Yes! Mines looks now the same :c

Bad. Pixelated.

And there is a weird bug with the view… its like a frame around the reflections… is it a scene base shader that takes the render images and just projects them?? :expressionless:

This is solved: But there is a new mytery… it only works with AA level 2 and higher.

First thing to check is your PostProcess volume setting, go to the SSR tab and ensure your “Quality” setting is at 100% (default is 50%).

The pixelation in version 4.8.x is very noticeable (as you can see in my image above), but good news is the quality has been improved in 4.9. There is a way to increase the quality even further by editing the BasePassPixelShader.usf shader file, for more info on that see this post. Increasing the value to 24 does increase the quality quite a bit, and with both 4.9 and this value increased, it looks really good.

Yes it is projected from the render image. The frame comes from how screen-space refelctions work, they only operate on what can be seen in your viewport, closer to the edges has less detail since it can’t compute what is off-screen.

For now it’s the only reflection system available, before version 4.8 it wasn’t possible to get any real reflections. Hopefully they continue to improve with each release.

We are realy lucky :smiley:
Thanks for the support!!!