Weird shadows while moving

You can see the weird shadows on the floor, I activate the point light component on the character, the light seem good, but when I start moving these shadows appear they get more obvious if I sprint(750 movespeed or something), I tried making the point light moveable, but I didn’t build the lightmap, anyone knows what’s going wrong here?

The light source should be movable if it is moving with the player(which is the torch.) Is the light has a source radius larger than 0? And is it’s source intersecting with any of the character meshes?

point light is on tip of the wand, I made it moveable but maybe it didn’t work because I didn’t build lighting, I’ll try putting light to a more open space now.

I tried removing the fire making light radius and length but no use, guess I’ll have to build lightmap, but it takes 2 hours so I can’t respond any earlier, thx for help

Movable lights dont have anything to do with lightmass and this doesnt have anything to do with it so dont build the lights right now. Post some screenshots of your light’s settings and the character BP viewport instead.

okay let me see

I just experimented a bit, when I stand somewhere no weird shadows, but if I take one step and stand there shadows appear and they won’t disappear either even if I’m not moving.

Whoops I deleted the image

Don’t know if it helps, but I turned on the floor and the light looks like this.

Set the radius and length of the light source to 0. If it doesnt work delete that light and add a new one. If still no go then there must be an intersection with other components in game. In that case set a third person camera and look at the character from behind to see what is going on as you move around.

Now the problem looks more familiar, but it still doesnt make sense to me. The only times i see this issue is when the light’s attenuation radius is too high with the light located far away from the surface. Could you try migrating your character BP to a new project and see if the problem exists?

I made a new light, disabled all precomputed lighting(all dynamic now), still trying, I’ll write here if I find solution

I made the mesh invisible but shadows didn’t die, by the way I noticed that shadows change completely with the camera angle

Just now I dragged a point light to the map and same thing occurs, I started playing with world settings

I don’t know if it’s the real solution but when I disable cast static shadows on the light’s details panel, the problem no longer exists.