VS2017 Fails to Start Debugging

Hello all

UE Version 4.15.1

My problem is when I try to debug using VS2017 I receive an error after building completes. Here is my log


I am not sure why such a problem happens, any help would be appreciated. Thanks in advance

You typically get line 2 in your log when you open a project configured for VS 2015 with VS 2017. I’m not sure whether this is the cause of your problem, but I had a lot of strange build errors with these kinds of setups when I upgraded to VS 2017. Perhaps you could try rebuilding the project files for VS 2017 and see if that helps. I generally put the following entries into my config files:


in DefaultEditorPerProjectUserSettings.ini (this is not necessary for creating the VS 2017 project files, I think, but it causes the editor to open VS 2017 when using the Open Visual Studio menu item), and


in DefaultEngine.ini.

Thanks you for this, these two lines are now gone, but I still can’t debug ;_; I am getting this message now. It says: “The operation can’t be completed. Undefined error.”

I am guessing this is because my vs2017 installation isn’t done properly

I have tried reinstalling, but nothing has changed…

If anyone has experienced this problem and has found a solution, it would really help

Does this only happen with this particular project, or do you get the same error when you create, e.g., a new project from the Third Person C++ template?

I can debug using Qt Creator, which means there is a problem with VS2017 toolchain, either missing or not configured…

But since I can debug with Qt Creator, it means there is a configuration problem?

I am busy with RL at the moment, I will get back to this post in a few days, so please Epic do not mark this as answered yet!

I failed to find a solution regarding VS2017. Even formatting the computer didn’t help.

It was fine to use VS2015 and Qt Creator is also working just fine, but not VS2017. I am just a ■■■■■■ for changing to VS2017 this fast. I should have waited a bit longer…

I guess I will stick with Qt Creator. It would have been better to use both at the same time like I did before, but whatever… Anyways, thanks for helping me Matthias Hölzl.

By the way, I have a few things to say to Microsoft.

Dear Microsoft

If there is a language selection for a program. Please make it so that the installer' language also changes, not just the installation' language.

P.S.: There will always be translation errors around. Don't forget that.

The OP may have solved it by his own or moved on in the meantime but in case anyone else encounters this problem with VS 2017: i also had this problem and it drove me nuts for several days.
In my case the solution was pretty simple and exactly what the editor was saying: fix your Debug settings.

I entered these settings in the Debug settings panel and everything worked as expected: c# - Cannot Debug in VS2017 with Windows 10 - Stack Overflow