VR template, change teleport spline settings

Hi everyone,

I am trying to change the settings of the spline line in the teleport. I would like to minimize it size to be less visible. I tried to find it inside blueprints but I didn’t find where I can change it appearance.

Thanks in advance!

If it is the VR template, then you’ll find the arc mesh in VirtualReality\Meshes\BeamMesh.
In BP_MotionController the function Teleportation\UpdateArcSpline controls drawing the spine, so go to the ‘add spline mesh component’ node, and open the advanced settings under ‘Spline Mesh’, finally set ‘Start Scale’ and ‘End Scale’.

Good Luck.

Work like a charm!

Thank you again Salm!

Talking about “Spline” There is something else that I would like to change. I placed a widget interaction component inside the BP_MotionController and I created some widget, using the same technique that I used in my other thread https://forums.unrealengine.com/showthread.php?147531-Vive-handle-Menu , except this time for my main menu. Everything work fine (EDIT: well not completely true… the “on hovered” style appearance is still not working when I point the buttons with the motion controller) but, personally I find that the debugging “show debug” option is very ugly, I would like the personalize the ray trace.

here a screenshot where you can see the “show debug” raytrace and the “on hovered” that is not working


I had a similar problem with “on hovered” for a Button with a TextBox child, my solution was to change the visibility of the TextBox child to ‘hit test invisible’. In my case the text box was stealing input from the button i could only click on the sides of the button. Do your buttons respond to onClicked events normally?

As to the laser pointer arc, I’ve looked at UE4’s VREditor for inspiration, and you can even find the laser pointer material in the Engine Contents of the Content Browser. I haven’t actually finished anything though, so I can’t say too much about it.

I use a simply “text” child instead of a “textbox”, but it can create the same problem that you had. I tried to change the visibility of the button, but I think I didn’t try with the text. I will try this, thank you. Yeah my buttons respond perfectly to onclicked event.

For the laser pointer, I would try to find the material in the Engine content. There is a solution, because I saw some example where people create their own pointer appearance.

Today I tried to change the visibility of the text, but it didn’t work.

Hi again!

Someone have a solution for this?

Thanks again!