Download

VR Preview crash when Event Begin Play used - 4.27.1

Downloaded the hotfix without thinking, and it’s messed up my project. Anytime I load VR Preview I get a full crash of Unreal Engine and I have to end process.

Currently I’ve nailed the problem down to the event begin play, but nothing to do with my functions - even if I link a print screen to it, I crash.

Was working perfectly on 4.27, what’s changed??

Any help is much appreciated.
Cheers!

1 Like

I seem to be having this exact issue as well. I have tested it further and i get this issue on event began play but also on event construct

As a follow up i cannot reproduce this in the VR template

Yep, mine is the same. VR Template seems to work fine but I’m already into a project so that doesn’t help much. I didn’t work out what was causing this still, it seems intermittent for me.

So i can make it happen consistently in my project. Tomorrow or Wednesday my plan is to start a project in 4.27 and upgrade it to 4.27.1 and see if that will force the issue in the vr template.

My current running theory is its an issue with the update from 4.27 to 4.27.1

Would be much better if the crash log is uploaded here…

I can consistently replicate the crash on an almost stock VR Template project created from before 4.27.1 after updating the engine. This does not happen with projects created in 4.27.1.

At least for me it crashes in the VR runtime after submitting the first frame with xrEndFrame. Debugging it I couldn’t see anything out of place with the frame submission at least.

Tested with the SteamVR OpenXR runtime on Windows 10.

Log:
VRTest_4_27.log (105.8 KB)

1 Like

On my system i don’t actualyl get a full crash but instead i get really bad renderer artifacts all over including the editor, but I run my project directly from visual studios, instead of the regular launcher

@VictorLerp since i see you lurking around today, per answering another post of mine. Can you weigh in here? Is this a known issue, or do you have thoughts on what we can try to trouble shoot further?

Summary: OpenXR seems to have issues when there is code in the event begin play or on construct in UMG. The other post on here are getting crashes, and i am getting some kind of render artifact.

This issue seems to be new with 4.27.1 if the project was created before it. This issue does not seem to happen on a newly created project in 4.27.1

I looked at this but if it can’t be reproduced it’s very unlikely that we’ll find the cause and a fix

@Rectus_SA was able to get it to happen consistently by starting with a project from before 4.27.1 then upgrading it to a 4.27.1 project

Here are the crashing project files. I can’t remember if I changed anything in the template, but if I did, it shouldn’t be significant.

https://drive.google.com/file/d/1Sif-Z3xp_S-rUSDJa3wohzWbqN9YSRi1/view?usp=sharing

Has anyone experiencing crashes etc try deleting the intermediate folder and re-run?

Yes. Before posting the project above, I deleted everything except the Content and Config folders and ran the project again with the same result.

1 Like

Yes i have even clean and built from VS everything and still get the issue. My team is looking at trying to start a new project and just migrate all our assets over to see if that make a difference. It may be a bit before we do that, but if this isn’t resolved by then i’ll post an update on it.

Hi everyone, I have some additional information on this.

When using OpenXR this issue only happens when using the Varjo XR-3 HMD, with the Oculus Quest 1 and a Reverb G1 this issue does not happen.

Also additional info:

We created a new project with the VR template in 4.27.1 as the base map, and imported all of our assets from our main project. We were able to bring all the assets into the VR template without issue other than a similar render issue on our 3d widget UI piece (The only thing really special about this UI is it uses a translucent material). However when opening our main map after imported into the project created with the VR template, we do get the same issue., where the render has really bad broken artifacts.

Also as i noted above we do not get this issue with other HMD’s running the OpenXR, only the Varjo XR-3. My teams current running thought is that it has to do with the renderer and the QuadScreen setup of the XR-3. The weird thing here though is that when we run the XR-3 with SteamVR we don’t have this issue, but we cant use the Varjo OpenXR plugin with SteamVR which means we cant do Eye Tracking and Hand Tracking, unless we can get the OpenXR plugin to work as well as the SteamVR one does.

Varjo’s XR-3 is a one of a kind HMD! You can find specifics on how to work with the XR-3, OpenXR, and Unreal Engine on Varjo’s documentation: Recommended Settings | Varjo for developers

Yup we have done all those setups and have been working with Varjo directly, but still haven’t been able to solve this issue. the closest through at the moment is that we need to wait till the pull request from Varjo that updates Unreal to allow for more than 2 HMD screens for the renderer.

Which sucks because we were able to do all of this stuff before 4.26, before the full switch to OpenXR :frowning:

There’s an update to Varjo Base (3.3.1) that’ll be released sometime next week - it contains a fix for rendering artifacts on the XR-3 when Stereo Layers are used. Keep an eye out for that update and let us know if it resolves your problem!

1 Like