VR Pawn in VR Template won't generate overlap events?

Hey there,

The VR pawn won’t generate any overlap events and I have no idea why. I’ve even given the hand meshes the ability to generate overlaps but so far the pawn is not firing the overlap.

It’s probably a simple solution. I asked a similar question before and the answer was setting the bool for Can Generate Overlap Events to true for components and objects, but in this case…nothing :frowning:

Here is the logic (super simple). Any pointers would be great :slight_smile: Thanks!

Start with print string straight of the vr pawn cast node to help troubleshoot if its actually firing.
Make sure the trigger overlap event box is ticked on the collision settings.
make sure the channels are set to overlap.

I’ve noticed the motion controllers in the VRPawn BP in the VRTemplate for 4.27 do not appear to generate overlap events, I’ve tried so much but the only results I can get are by attaching collision spheres to the controllers, that does allow overlap events now.

there’s presumably something in the VRPawn BP that I’m missing.

Hi I don’t often post here but in this case I feel I really need to for other developers in this weird situation. For me anyway none of the info on this page worked however it may be correct.
The reason my VRpawn wasn’t making any overlap events was because it didn’t have it’s own collision capsule. So simply go into your player pawn and give it one:) Having given the new VRtemplate’s VRpawn it’s own collision capsule, all of my collision events boxes in game started working again…

6 Likes

Hi, I added two capsules for each side of the controllers in VR pawn, and checked that it can generate overlap events, but just when I try to cast it in the level blueprint, it’s not working. Could some master give some tips on how to cast it in level bp?

I’m trying same thing for UE5, can’t make it work!
Any help?

This resolved this issue for me. When setting up a simple collision box to turn on a light, in VR the OnOverlap events weren’t triggering. As soon as I added a collision capsule to the VRPawn provided in the VRTemplate, my blueprint started working as expected. Thanks for pointing this out.

I got it working, see here: VR Motion Controllers won’t generate Overlap events! : unrealengine (reddit.com)
TLDR:

  1. Open VRPawn Blueprint
  2. Select the HandRight Skeletal Mesh
  3. Under Collision, click “Generate Overlap Events” and Select “OverlapAllDynamic” from Collision Presets
  4. Open the Skeletal Mesh
  5. Go to Physics Asset and create a new Physics Asset.
  6. Add Collision to the physic asset
  7. Repeat for other hand
1 Like

Thanks Julius. That worked for me, now can use the hands for open/close doors.

This worked for me! Thank you!! :pinched_fingers: