VR disable teleport during level sequence


What I am working at: (just for a better understanding)

I try to develope some new kind of artwork with VR. I want to mix the classical artstuff, like painting, videoart, sculpture, photography and poem to one big artworld.
Therefor I am using the “normal” structure of pc games. Going from Level to Level, finding keys to open portals and so on.

My Problem: (You could read from here)

As the title says: I want to disable my teleport function during a level sequence is playing and after that I want to reactivate it.
I am using the standard VR Template, so in some levels teleport is the only way to move.
I tried many different things, but nothing seems to work:

Starting from EventBeginPlay:

1.) Using Blocking Volumes.
a.) If I use it as a wall, you can easily teleport behind the wall.
b.) If I use the blocking volume directly on the navmesh, it won’t update the navigation in game. (tried it with destroy actor and set collision)
2.) Using Navmeshmodifier (set area class)
same here: it won’t update the navigation, so teleport is still impossible.
3.) Using the sequencer
tried to move the blocking volume away, but this won’t work either :stuck_out_tongue:
4.) Tried to delay the input of the BP_MotionController
I am bad at BP, so this was also not succesful. Either the input is totally disabled or enabled. But I can’t do it for just x seconds.

I think it is not that difficult, but I am missing the point. And also I am not so good with BP. So theoretically I know what to do, but I don’t know how to.

If anybody could help, I would be really thankful.

Best wishes


Hello ,

To do this you will need to dive a bit deeper into Blueprints. I’d accomplish this by creating an ‘AllowTeleportation’ boolean in the MotionControllerPawn.

Then on the InputActions (TeleportLeft and TeleportRight) I’d use a Branch node → If ‘AllowTeleportation’ is true, activate teleporter. If it is false, do nothing.

And then, for example in your level blueprint: Get Player Pawn → Cast to MotionControllerPawn → Drag off from “as motion controller pawn” and set your ‘AllowTeleportation’ variable.

I like your idea of ‘one big artworld’!

Hello ,
Thank you very much for your quick response. And also that you like my idea.
I will try your recommendation tomorrow, when I am at my desktop. And I definitely know, that I will have questions. So if it is okay, I would like to ask you tomorrow :_)

Good Morning,
Yes, it worked. Thank you so much! This was actually pretty easy and understandable, so I don’t have to ask you any question. :slight_smile:
, you are the best!