Volumetric Rectangle Light not working

Dear support,

I am trying to recreate a technique I used once without success.
Basically my goal is to create a light rig that produces volumetrics, like this:

In the past, I used a rectangle light + a light blocker mesh in front of the actual light. When adding the Exponential Height Fog Element to the scene, the rays show up nicely.

However, doing this again on another project, I am not getting the desired effect.
This is my model blueprint:

and this is the result:

What am I missing? or is there maybe a better way of getting this result?

Thanks in advance,


Most likely the light is not set to cast volumetric shadows, or you’re using raytraced shadows which don’t support volumetrics.

You’d most likely get better results with a spotlight, this really doesn’t seem like an appropriate use of a rect light.

Hey Arkiras,

Thank you so much - it indeed was the issue.

With the spotlight I am getting cute results, but not when I try to activate the gobo effect with the mesh covering the spotlight.

Then I’m barely seeing the effect, unless I raise the Volumetric Scattering Intensity, which in that case the result is very blurry/low quality.

Any tips about how to make this happen better?

There’s no need to raise your intensity so high, you can increase the volumetric scatter intensity beyond what the slider will allow by typing the number in:

The noise is probably because the holes are so small, you may need to decrease the voxel size of the volumetric fog using this command: r.VolumetricFog.GridPixelSize

The setting defaults to 8 (I think), lower numbers will capture finer detail at the cost of a lot of performance. I wouldn’t suggest going below 4 if this needs to run in realtime

Using an intensity of 20 + 250VSI I’m getting nothing at all, I tried 200 instead, still getting a very subtle result compared to yours which looks clean and crisp.

Also set the pixelsize to 4 but it didn’t help (I’m loading the fog element via BP) cause it can be turned on/off

What did I do wrong?

I can only assume its related to the size, volumetric fog generally cannot capture small details. You can try setting gridpixelsize to 3 or 2… but expect a huge performance hit…

Only other thing I can suggest is maybe try using a light function instead of a blocker. If the issue is with the shadowmap resolution that should fix it. Again though this will probably come at a performance cost…

The light function idea sounds great, but on my end it ignores the setting,
Is there another setting somewhere to make sure it works?
I’m on 4.26

light function 2

Thanks again for everything

any updates here?

thanks again

Another update:
I upgraded to 5.1 to check the matter, so light functions work now,
but I don’t get the same clean ray as you, the areas closer to the beginning of the spotlight are super pixeled, even thought I’m on pixelsize 4:

Any tips about how you got such clean smooth ray?

Thanks again