Download

Volumetric Fog feedback thread

Hello,

I just start on ue4 and I’m working on my first project, so i want to apply a local volumetric fog, and I already follow the instructions to do it with the ue4.21 version and it worked very well, so now I wanna do this again in the ue4.23 and it doesn’t, I don’t understand why.

I made the material, I customize it a little, after that I run it through a particle, set the light and the exponentiel fog and it worked. I do all this once again, I read all the volumetric fog ue4 docs, and idon’t what I forget.

So, it will be welcome if someone can help me to solve this problem.

My computer run with
-i7 4770
-16GbRAM
-nvidia GeForce GTX 1060 OC

Thanks for your help!

Any workarround?

I have a project with Niagara plugin enabled on UE4.22.3 and I am following this tutorial to build a fog particle system. https://www.youtube.com/watch?time_c…ture=emb_title However, I first tried to create the material and apply it to a Niagara particle system, I’ve gotten some errors, so I deleted that particle system from content and project and went back to implementing exactly how it’s done in video with a regular cascade particle system. However, my material is getting errors related to Niagara still, and it’s not rendering properly. I’ve attached a screenshot of the material function and errors. Anything I’m doing wrong? maybe I should disable Niagara? I’m using it with another particle system that works fine, so I’d rather not…

UPDATE: I upgraded the project to 4.231 and I get the error:

[SM5] /Engine/Private/VolumetricFogVoxelization.usf(61,33-110): error X3004: undeclared identifier ‘VertexFactoryGetTranslatedPrimitiveVolumeBounds’

UPDATE 2: I disabled the Niagara plugin and the volumetric material now works… so It’s not possible to use volumetric materials with Niagara? Or should I do something different?

Did you ever manage to solve this? I’m getting a similar error when using objects lighted by channels different than 0 - https://youtu.be/-1FZkZJtIvE

Is it normal for the fog to react this way for objects using any lighting channel combination other than straight Channel 0?
[video]https://i.imgur.com/ZTe0GR0.mp4[/video]

https://www.youtube.com/watch?v=-1FZkZJtIvE

This was working in 4.22

https://www.youtube.com/watch?v=SzfSicYrzPc

@inedible.red

Are you using static, stationary, or movable skylight or directional light (the light that’s lighting the whole scene)? It appears that using the selection box function, whether to select a character or simply starting to use it, triggers the problem. It could be something in the volumetric fog material’s settings, such as domain or if it’s not set to per-pixel (default is per-vertex). Post this in AnswerHub and see if you get more knowledgeable replies? In here it’s likely to get ignored.

All my lights are movable. Selecting makes visible the character “selection ring” (golden circles) that’s using the lighting channel 1. I can replicate the problem by just adding a mesh in-game and switching the lighting channel 1 on and off.

“All my lights are movable. Selecting makes visible the character “selection ring” (golden circles) that’s using the lighting channel 1. I can replicate the problem by just adding a mesh in-game and switching the lighting channel 1 on and off.”

I have encountered a similar issue where viewing the scene from above it, or at a steep angle to it results in the lighting going super bright, at a gradual rate rather than instantaneously. I’m wondering if it has something to do with lighting channel 1. Does it need a specific setup before using it? Why would adding a mesh or using channel 1 or not cause the problem or not, respectively. Or is it another one of those ‘defies simple logic’ problems that UE4 is infamous for.

Is the scene using an LPV (light propagation volume)?

The whole scene is dynamic so I don’t need a light propagation volume… I think? I have a few other things that got push forward from my backlog but I will try this configuration on a clean project as soon as possible and submit a bug report if necessary

The LPV is a dynamic lighting feature. It basically enhances dynamic GI (global illumination), according to the doc page on it, at least.

Dont use lpv, it has been dead for i think over a year.

Some comments :
" Your getting there, but LPV has been abandoned for over a year now, give or take a few months " https://forums.unrealengine.com/deve…ytracing-noise

" Are you both utilizing Light Propagation Volume at all? It has problems with self-shadowing and back in version 4.20 cannot be confused with Lightmass GI because it is somehow not compatible by being dynamic GI "
https://forums.unrealengine.com/deve…n-meshes/page2

Here prob the best evidence https://forums.unrealengine.com/unre…consoles/page2 , " Originally posted by darthviper107 View Post
I think LPV was abandoned because they want to do something better, though I guess by now they could have gotten LPV to a usable state until they could get a good dynamic GI system in.
This and probabaly lack of company push in this direction (noone is interested and they don’t need dynamic GI for their games). "

So ya, I’m yanking it too.

Is this feature planned ?

If the LPV could be detached from the camera, and its size changed, it would be useful.

Does this temporal filter take into account screen resolution changes from dynamic resolution? I seem to be seeing artifacts from that that I don’t notice when dynres is off, but am not completely sure.

Hi I cant seem to render Volumetric fog in a short animation when using Sequencer

Please see attached pics.

First Pic is what I want to render. The second pic shows the rendered animation from Sequencer, no volumetric fog renders any help would be great.

Yea, my volumetric fog will never look as good as the first image, I can’t use witchcraft, no matter what I do it will always look like garbage.

Any way we could get a joint volumetric frustum grid for stereo rendering/VR? Seems like we could get close to 2X the grid resolution at same perf if the headset’s eye overlap was high.

edit: visualization

Volumetric Fog seems to be unaffected by the Indirect Lighting Intensity setting in the post process volume, just wondering if this is a bug or if this is just a limitation of volumetric fog?

It seems unusual to me since it is using volumetric lightmaps, which are also used to light moveable objects and they behave correctly with the post process setting

Hello guys. I’m using the UE 4.25 volumetric cloud system, my issue is that when I move the camera for example move it 20m up in the air, the ground fog seems to follow it so there is no spacial impression, the fog is like glued on the camera lens. Did anyone face this? Any solution? Thank you guys for your time.