Download

Valve Index2 --- not loading UE4(4.26 preview6) VR preview when using the Groom plugin

I created a new Virtual Reality project and tried to use Groom to create character hair.
When I play with the VR Preview option and the HMD moves to the hair position, this time the Editor quits due to an error. But when I play with Selected Viewport option, it works fine, but of course there is no VR effect.

Here is the message when the Editor quits due to an exception:
“Assertion failed: DebugData.bAllowRHIAccess [File:D:\Build++UE4\Sync\Engine\Source\Runtime\RenderCore\Public\RenderGraphResources.h] [Line: 112]
Accessing the RHI resource of CategorizationTexture at this time is not allowed. If you hit this check in pass, that is due to this resource not being referenced in the parameters of your pass.”

Additional information, RTX2080 Ti and SteamVR latest Drivers and DirectX 12

Here are some screenshots:


QQ截图20201110201116.png

I have the same problem with 4.26 release version and my Oculus Rift S…

Have you found a solution to this?

Just wanted to chime in that I’m having the exact same problem with a Quest 2. Here’s what I’ve found out:

  • It’s not the VR device that causes it to crash. Running it in stereo mode crashes it out, even if no VR device is connected.
  • It doesn’t seem to be performance related. In our case, our framerate was well over 120 fps, and we weren’t putting any serious strain on our computer.
  • We could get it running for a second if you’re looking away from the groom. It only seems to crash when the camera looks directly at the groom.

It seems to be a render pass error? Not sure how to access the settings for render passes.

1 Like

We have managed to get it to stop crashing. The groom now runs in VR. Sort of.
Main issue now is that it only shows up for the left eye, and we have no idea why.

Ok, so disabling “cast dynamic shadows” on all movable lights will allow it to run without crashing. Runs perfectly fine, but with two problems. First, obviously, there are no shadows. Second, it will only render for the left eye, not the right. No clue why this is happening.

Some notes

  • It doesn’t matter if the groom is being lit by a dynamic light or not. As long as there’s a dynamic light in the scene, it crashes.
  • The groom’s own cast shadows options don’t have any affect, and you can’t assign an unlit material to it.
  • Setting lights to static will cause it to not crash, though they won’t allow the groom to cast shadows either.

That’s all I’ve got. I’ve tried changing more or less every other setting I can think of, none of them have any affect.

Picking it apart in render docs also wasn’t able to shed much light on why it only renders in one eye. It does attempt to render the right eye, but then it just renders nothing. No clue what’s up with that.

3 Likes

Did you fix the “left eye problem” ? I have the same issue here.thank you

NOPE. Still haven’t fixed it as of 4.26.2, though we haven’t tried it in 4.27 , but I have not seen anything that indicates it would be any different.

Unfortunately, the issue seems to be at the engine level. The engine does run the render pass for the hair for the left eye, it just renders nothing and we still don’t know why.

Have not tested in 5EA with Lumen, though, so I suppose there’s a slim chance it could work, but I’m not super hopeful. For now, we’ve moved to only using cards, which definitely sucks.

Since this thread got resurrected I wanted to chime in and let everyone know that we’re working on supporting Grooms for VR. Earliest you can expect it would be in 5.0.

1 Like

We had the same issue, and the reason was because we had a metahuman in our scene with Alembic Groom hair system on it. As soon as we removed the metahuman characters from the scene, it started to work again.

1 Like