Using a Day/Night cycle, but the nights have a wierd light going on


So I was trying to use a day/night cycle on my project. Was simple enough to do, but I have some trouble with the lights on the night time. I did some searching and found out turning down ligthmass or changing environment color in world settings would help, and it did, but it makes everything too dark. So I tried to add a little bit of light (tried both a skylight and slightly lighter world settings) and here is the problem: When the sun goes down, it gets darker, but when the stars comes to sight, the whole level gets brighter, and when the sun comes up, it gets darker, and then turns to daytime.

What I want to have is a light setup that does not make it brighter in the night time, but I can’t figure out how =/

Picture trying to show what I mean:

Hi Andy,

I have a sample project here that may help as well: [TUTORIALS] Photons Be Free: Mini-tutorials and other curiosities - Community & Industry Discussion - Epic Developer Community Forums

This is a day/night cycle based around Gregdumb’s Wiki Tutorial.

I’ve extended it to use a skylight that fades in and out it’s intensity when the sun is below/above the horizon line.

If you’re using a skylight you will want to essentially set it’s intensity to get the look you want during the night time. In my example I use a very low intensity for the night since I wanted to have it go nearly pitch black, but still have a little bit of light.

The World Settings > Lightmass > Environment color shouldn’t have any effect on your dynamic day/night scene since these are specifically used for pre-computed (baked) lighting.

I hope this helps.


Thank you!
At first nothing made a difference, but I found out that you set 1 as min and max brightness for the Auto Exposure in the PostProcessVolume, which i didn’t.
And that solved the problem :smiley:

ah, right. I tend to forget about that since I usually set up a post process in all my levels and get rid of that first thing.

Glad that worked for you! :slight_smile: