Use Lumen and static lighting in the same project?

Is there a way to have two different levels/maps in the same project, one using lumen and the other one using static baked lightmaps ?

It seems that it is an all or nothing option but I’m not sure. I believe that some environments benefit from static lighting as you get a higher quality and lower processing costs from baking compared to lumen. It would be nice if lumen was something you could activate per level or map.

Yes you can do this, by setting the GI/reflection method in the post process volume.

This will work as long as you have “Allow Static Lighting” enabled in your project settings, and the level is not a world partition map. World partition does not support static lighting yet.


Tested it and it seems to work
I have a small scene where I have baked the lighting and if I move the camera outside the Post Process Volume, which has GI set to none, then lumen kicks in and does its thing. Pretty cool.

Thank you for the info. @Arkiras

To expand upon this subject.

There are some lumen features that won’t work unless Allow Static Lighting is disabled in the project settings. One of those is Material Ambient Occlusion

Not sure why it works this way. But it would be cool if we could get this to work without having to entirely disable static lighting.

1 Like

Says in your screenshot, need to disable it to make space in the gbuffer.

How would I go about setting this up in Blueprint where I can change this specific Post Processing Volume setting in a settings menu during the game? I have a lot of other settings already coded that work (by work, I mean I can apply them and load them successfully and they make the proper changes) but I haven’t linked any PPV settings yet so I am a bit puzzed on that one. Thank you so much!

If you disable Lumen by cvar then it will fall back to using lightmaps (if you have built them). So you only need to use the setting to set the cvar. This is how the scalability settings work, by default Lumen is disabled if Global Illumination scalability is set to medium or lower and it will fall back to lightmaps if they exist.

But if you want to set the cvars manually you can do it via:

r.Lumen.DiffuseIndirect.Allow 0

If you also want to disable Lumen reflections (will be used with lightmaps if hardware raytracing is enabled) then you can also use:

r.Lumen.Reflections.Allow 0

1 Like