"Use emissive for static lighting" for objects inside blueprints

I’ve made a blueprint with a static mesh component inside. I’ve set its mobility to static but it still doesn’t receive any baked lighting from emissive objects with “Use emissive for static lighting” ticked.

Am I forgetting something?

Hi Supermtf20,

I’ve not been able to replicate this on my end.

I have a test scene with three cubes.

  1. is a static mesh with a bright emissive material on it. I’ve enabled the option in the details panel for “Use emissive for Static Lighting” for this mesh.

  2. is a static mesh cube with a white material in a Blueprint with its mobility set to static.

  3. is a static mesh cube with a white material with its mobility set to static.

Using this setup I’m able to get statically baked emissive lighting on my two static meshes.

Hi Tim,

I made a similar setup to the one described in your answer and it worked great.

Next, I reopened my project, the one that had the baking issue, and tried baking one more time. To my surprise, it just worked !!
It’s either some setting that I mistakenly altered or some sort of bug somewhere.

Anyway, thanks so much for your help.