Upgrade 4.7.6 -> 4.10.1 Material stopped working on a specific mesh

I’m having a strange issue with a material that stopped working only on a specific mesh after a recent upgrade. If I look at the material in the material editor it draws fine. If I put it on another mesh it draws fine. Of course the mesh it was originally on no longer displays (I just get the default grey checker material)

The material is a somewhat complex water shader that uses displacement and shader functions.

Anyone got any ideas what might have caused this or how I could debug it?



Hello ook,

Would you please provide a screenshot of your material along with a screenshot of the working and non working mesh?

Here’s the info you requested. Is it possible that limitations were added for very large meshes?

After noting the very large mesh size I tried some tests with different poly counts and lowering the poly count seems to have fixed it. I’m still left with needing that mesh to be really big but I can always break it into a number of sections if that’s a new engine limitation.

Interesting. There could have been an issue when updating from 4.7 to 4.10.

Make a copy of your Project before trying this

You can try and delete your Intermediate, Saved, and Derived data cache directories form the your project. This will force your project to rebuild when you open it next. If it is still occurring after this would your provide a text project with this material and it not working on a high count polygon mesh.

Thank you,

Can you show me the locations of the files / directories I need to delete? I’m not sure where they are exactly.

They are in the main folder where you have your project saved. Navigate to the folder that holds your project and it will be within the first folder you open.

Unreal Projects > ________ > Intermediate, Saved, Derived Data Cache

When you say “Intermediate, Saved, Derived Data Cache” Do you mean delete the folders with these names inside my project folder? Sory for being so nitpicky but creating and restoring backups is time consuming and tricky given my source control solution.

I don’t appear to have anything called Derived Data Cache.

Yes, your project folder where you have your project saved on your computer. Not the folders inside of the project itself. You should be able to copy and past the project folder to create a test for this.

Deleting my “Intermediate” and “Saved” directories did fix this. I didn’t have a “Derived Data Cache” folder.

Can you explain what was at work here? Just would like to better understand it in case I run into future issues.

Thanks again!