Updated Quixel Bridge Broke Packaging

Updated to Latest Quixel Bridge, now I get:
UATHelper: Packaging (Windows): LogWindows: Error: [Callstack] 0x00007ffefcba0659 UnrealEditor-Bridge.dll!UnknownFunction []

and cant package

Confirmed. Deleting ue5ea\Engine\Plugins\Bridge\Source\Bridge fixes error.

Dont update to latest quixel bridge if you need to package

Would you happen to know how to do a roll back of the plugin?

Just delete the entire ue5ea\Engine\Plugins\Bridge\Source\Bridge. Doesnt rollback but removes entirely and you can package again.

we’ve encountered this issue in another thread, here you go, a version of bridge before the update

1 Like

So, I’m going to add the following information to this thread…
Was trying to use the lastest UE5.0EA (2), with the QxBridge &internally adding content. Bridge had been updated (not knowing this issue), and it caused a ‘background process not started’ error when the Bridge was brought up. It would constantly cycle through ‘not started’ and ‘starting’… I wasn’t signed in, (but yet, i was!) I could not sign in as it said it was an “invalid attempt”. I had the Epic Launcher ‘validate’ the install to see if it would fix it. It did not.

I removed the Bridge folders and installed the Prior version, per the link in a prior post.
That fixed it to a point. It could see my login (and my account). I should be able to drag an asset into the view and it should initiate download. It does not.

I was able to get a few Materials to download - and it finally placed the Megascans folder in the Content Browser window. I then tried with Mesh … and it hangs up. I checked the download area and i get a ‘waiting’ indicator… (for what?) Sometimes i can Cancel the download, and get it to start again, but it still doesn’t add it to the Project.

Once it downloads, I can see the green checkbox - and the blue + ADD adjacent. Clicking on the Add button does nothing. I’ve tried multiple projects with no joy.
Any Clues?

UE: 5.0.0-16682836 +++UE5+Release-5.0-EarlyAccess
QB: 2021.0.2

*EDIT: follow up on the ‘downloaded content’ mentioned above. Only the (2) Materials were downloaded. The other content is not in the Megascans downloads folder, as the other assets are, and not in the Download folder. Unsure if they actually got downloaded or not.

Hi guys - please email support@quixel.com for assistance with this issue. One of my agents will help you as soon as one is available.

OMG, good to know lol. Luckily I’ve been too lazy to update it.

Thx… appreciate the heads up… Will do!

hI @KPaxx_10,
There was a thread that had a similar problem after logging with Quixel Support. They ask these questions and found the problem

  1. Please go to the following location: \UE_5.0EA\Engine\Plugins\Bridge\ThirdParty\Win

  2. Does the node-bifrost.exe exist in this location?

  3. What happens when you open it?

Basically, if you change or move the file you stop Bridge background from starting working as it is no longer registered with the firewall. Your virus checker will view this file as hostile and block or quarantine the file node-bifrost.exe.

Quixel Support may give more support, but this was the problem.

Thanks for the info! I checked for 5.0EA & it’s there - i clicked on it, and it opens up a black ‘terminal’ looking screen w/ a blinking underscore cursor. it doesn’t do anything else.
I checked with my firewall settings - and Bridge, as well as the other UE apps are set t be ‘allowed’, although i do not see a listing for Node-Bifrost specifically.

Hi @KPaxx_10 and everyone,
Please try the new update to Quixel Bridge described in

Quixel Bridge 21.0.4 Update to Unreal 5.0 EA2 Epic Launcher Binary version

This should incorporate fixes for the node-bifrost.exe problem as well as a fix for Windows Packaging/cooking