Quixel Bridge 21.0.4 Update to Unreal 5.0 EA2 Epic Launcher Binary version

Following discussion with Quixel Support
Quixel Bridge 21.0.4 Update from 21.0.3 to Unreal 5.0 EA2 Epic Launcher Binary version. Is released on 21st October 2021

Thank you for your patience!
We have just shipped an update to Bridge, which contains multiple bug fixes. Kindly update to the latest version of the Bridge plugin for UE5 and your issue will be fixed.
Please let us know if the issue persists!
Best Regards,

Product Support Engineer
Quixel -Epic Games

The Package/Cook problem amongst others has been fixed.
Here is a picture of the right place to get the updates
In the Epic Launcher, under the Early Access 2 download
Click on the “Installed Plugins!” to update Bridge to 21.0.4

Here is successful Completion


Click Close and open UE5 Early Access 2 using the desktop shortcut.

When you Windows Package/Cook you will get successful completion

UATHelper: Cooking (Windows): LogShaderCompilers: Display: Shaders left to compile 0
UATHelper: Cooking (Windows): LogHttp: Display: cleaning up 0 outstanding Http requests.
UATHelper: Cooking (Windows): LogContentStreaming: Display: There are 1 unreleased StreamingManagers
UATHelper: Cooking (Windows): Took 19.4036961s to run UnrealEditor-Cmd.exe, ExitCode=0
UATHelper: Cooking (Windows): ********** COOK COMMAND COMPLETED **********
UATHelper: Cooking (Windows): BUILD SUCCESSFUL
UATHelper: Cooking (Windows): AutomationTool exiting with ExitCode=0 (Success)

Thank you to all who helped me find the fault and get this fixed in particular @GPuthige, who brought the error to light in the first place.

If you get the following you have NOT followed the instructions above !!!

1 Like

Thanks a ton @Jimbohalo10 for taking this up and following up on a simple query from a noob like me :+1: :+1:. The acceptance into the community by experienced developers and users is really an ‘Unreal’ experience to me :grinning:

Thanks to the Quixel team for providing the update immediately and ensuring no break in service by the community.

Regards
Gp

1 Like

Hi ALL,
I have received feedback saying they can not package an OLD pre-update project.

That error means you still have the original plugin installed in your project 2021.0.3 still installed in your project.
You have to untick enable and restart the editor. Go back in find the Bridge plugin. Enable plugin again check the right number in the top right is 2021.0.4.
Restart the editor the NEW plugin is now loaded into your project and it works.

Well, that works for me anyway. The plugin code is enabled on a per-project basis which means you have to refresh the plugin code in your project

When I click on install plugin nothing happen …

I m sorry is working now …when I closed the engi n I can click on update …thanks epic team …

There’s 2021.0.5 now, aaaaand, broken again^^
I give up and use bridge standalone.

I was able to get 2021.0.5 for UE 5.0 source branch working by doing the following:

  1. From 5.0 EA, copy over both the Plugins/Bridge and Plugins/MegascansPlugin
  2. Disable the Bridge plugin, restart the Editor, then enable it again.
  3. The next time I start up the Editor, the Quixel Bridge windows just popped up along with the editor window.
  4. However there is nothing under the Import Content menu. If I close the Quixel Window I won’t know how to get it back unless I restart my Editor.

I’m using the 5.0 branch commit hash 9e3952afa2f3d0a3f66a250acb4647fb672a55c0

Edit: once I manually closed the Quixel window that used to pop up, it never came back again. So now I can’t figure out a way to bring it back and raised an issue to Quixel here https://help.quixel.com/hc/en-us/community/posts/4416808446097-Quixel-Plugin-2021-0-5-in-UE-5-0-source-build-doesn-t-appear-in-menu-

1 Like

Okay I recognized, my bridge window was already open in tab which I overlooked. So it only crashes, if I try to open bridge it twice =)

1 Like