Updated from 4.11 to 4.12 - Scene too dark and reflective

Yesterday I updated unreal from version 4.11 to 4.12
After I converted the project I noticed that things looked different. Everything is darker, more contrasty and some materials way more reflective.
If you look at the floor this is very obvious. The rough areas on the floor turned almost white in version 4.12
I already tweaked a lot of parameters but I still can’t replicate the look I had in version 4.11…
Any suggestions?

You need reflection probes and your lightmap resolutions are too low.

But I already have reflection probes and I didn’t change the lightmap resolution. Lightmap res is low because this is just a preview.
If everything is the same as 4.11 why should it look different in 4.12? That’s what I’m trying to figure…

Sometimes things like reflection probes break when you update a project from one version to the next. Double check that they are working and see if anything else broke.

Thanks for the suggestion. Reflection probes were not the cause. I deleted the old and placed new ones and the result was the same.

Yep, it looks like there is a problem with 4.12 roughness.

(Color/Metal = 1.0, Roughness = 1.0, 0.8, 0.6, 0.4, 0.2, 0.0)

It looks like the mips used for reflections in 4.12 are slightly higher.

That explains the results I’m getting. I wonder if it’s really a problem or if now it’s like this for a reason…

It seems so. To match the look of the 4.11 version I’m adding and SCurve to my roughness textures with values between .5 and .8. It’s just a workaround, surely not ideal.

I am seeing this same behavior. Very noticeable reflection differences. Especially with sphere reflection captures.

Just try to rebuild light. Works fine for me

Building the light was the first thing I’ve done. The problem is not there. :slight_smile:

Given that they tweaked the way reflection works, and you can specify different resolution for captures now, it MAY be that the default capture size changed, and if that’s the case, it MAY be that the values they had for calculating a reflection map MIP level bias based on roughness aren’t updated to match. If that’s the case, content will look less rough than previously, and the fix would be to select a smaller reflection capture size in sphere map settings.
Can you try that and see how it goes?

The meaning of roughness is not supposed to have changed with the new ability to specify reflection capture resolution. We’re looking into this.

I was able to track this down. I hoisted the max roughness mip count out of the shader into the c++ side and the “- 1” to get the max mip index was still being applied on both sides (in c++ and hlsl). I will have this fixed in the next HotFix. Thank you so much for reporting it.

Great! Thanks for looking into this. I’ll go back to 4.11 and wait for the hotfix.

Thank you Zabir

I have this problem also way too reflective, it only happened in my scene after I upped the light map resolution on reflection probes.

I’ve always wanted to sleep in a bed with vinyl sheets.

No, wait … :slight_smile:

I suggest waiting for the next patch update and hopefully Zabir will have it fixed!

I’ve changed my skylight cubemap resolution to 1024 and I’m getting sweet reflections as you can see on my chrome sphere but… Is there a way to use the cubemap JUST for lighting, not reflections?
It doesn’t match the scene as you can see. Even If I add a box or sphere capture probe, I only see the **** hdri! (I’m probably doing a rookie error, just can’t figure it).

If I use the planar reflections, it will override the hdri reflections.

My setup is dead simple. Stationary skylight + hdri and height fog… that’s it. No directional light.


This might not be quite the solution you want, but with 4.12 you can export a hdri image from a light probe. So you could put a light probe in the middle of your scene, delete/hide the house and just have the ground, trees, landscape, and sky, export that HDRI map, and use it as your skylight.