Unreal Engine 5 Only Crashes With VR Template

So as the title says, I’ve had no issues with unreal 5 thus far. However, it seems inside of vr projects, if i try to make a material, simple material with a simple texture node or even just a constant color, if i move any node it hard crashes the engine. Here is the error I get. Is this a known issue?

I’ve tried a fresh Unreal 5 install, fresh vr project, no luck, anything with the VR template just crashes immediately in editor, not even with anything to do with playing in vr
Assertion failed: CurrentGPUVirtualAddress != 0 [File:D:\build++UE5\Sync\Engine\Source\Runtime\D3D12RHI\Private\D3D12DescriptorCache.cpp] [Line: 729]

7 Likes

I wish I had a solution for you - I don’t.

Just posting here to confirm I am having exactly the same problem. Adding a new material is fine, but as soon as I create a color (3-vector) node in its graph, UE5 hard crashes.

It’s ridiculous to call it a “fix” but I managed to avoid having crashes by:

  1. Turning off all other target platform
  2. Switching rendering from DX12 to Volkan.

It chugs on, but hardly projects confidence.

1 Like

I can confirm this too. I had like 50 crashes the last 3 days. I tried to recreate the template but I got even more crashes ( controller position errors …. teleporting to infinity)
For the moment I will continue with 4.27.

Same problem - you’re right - it only crashes with VR projects. Creating a brand new 3rd person 5.0 project and you can create a material with a texture / constant 3 vectors without crashing. Reported @ Bugreport

Temporary fix seems to be setting the Graphics API to anything but DirectX12 (tested with DirectX 11 and it seems to work fine now).

1 Like

Have the exact same issue. Started several new VR Templates with Unreal Engine 5 and each time I add a node to a newly created material the editor hard crashes. This issue from 2019, although fixed, seems very similar to my observations: Unreal Engine Issues and Bug Tracker (UE-73255)

A crash report directly after creating a VectorParameter for example looks like this:

LoginId:13419cc340b8c75826016d94dd98d76b
EpicAccountId:

Assertion failed: CurrentGPUVirtualAddress != 0 [File:D:\build++UE5\Sync\Engine\Source\Runtime\D3D12RHI\Private\D3D12DescriptorCache.cpp] [Line: 729]

UnrealEditor_D3D12RHI
UnrealEditor_D3D12RHI
UnrealEditor_D3D12RHI
UnrealEditor_RHI
UnrealEditor_Renderer
UnrealEditor_RHI
UnrealEditor_RHI
UnrealEditor_RHI
UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_RenderCore
UnrealEditor_Core
UnrealEditor_Core
kernel32
ntdll

Thanks for figuring out a work-around. This was driving me crazy.

Reverting to DX11 isn’t really a viable workaround imho. You miss out on GPUlightmass and lots of the UE5.0 goodies. Crossing fingers it gets fixed soon™

Well, you could use Vulkan, which worked well for me, except that the Quest 2 Link connection is full of artifacts (does not happen when I shove SteamVR in between UE5 and the Quest 2 Link). If that is not an option for you, then maybe using DX12 and disabling “Instanced-Stereo” and “Mobile Multi-View” until the crash is properly fixed could work.

that actually could work for me so I could continue working on the project and test it in VR once its fixed again. Thanks for the suggestion.

Bug is now visible in the bug tracker - vote here Unreal Engine Issues and Bug Tracker (UE-148100)

1 Like

Tried the workaround (turning off instanced stereo), only afterwards saw the bug report mentions opening the project afterwards doesn’t work. Doh! Well I still have some prototyping to do in Blender I guess.

2 Likes

@biXen You can fix this ‘afterwards not opening bug’ by going to the config folder and edit the DefaultEngine.ini. Change the false to true in the line with vr.InstancedStereo=True

1 Like

Mine crashes while building lighting. I can only get around a crash when a level is empty.

1 Like

That issue is also in the same bug tracker - vote here Unreal Engine Issues and Bug Tracker (UE-148100)

3 Likes

Yeah, I saw that and did cast my vote.

I hope it won’t take months to fix it.

This is exactly what I encountered as well but I actually reported this to Quixel since I thought it was related to Bridge. Who then directed me to this thread.

I was also using a VR template and trying to create my own materials using textures brought to the project through the builtin Bridge; however, as soon as I dragged the texture from the content browser to the material window, UE5 crashed… and repeatedly, I even created a fresh VR template and tried it again and it just kept crashing.
Had to revert to UE4 eventually with standalone bridge.
I was planning to add parallax occlusion or bump offset using custom material since normal maps are useless in VR if you’re too close to them.
I was really hoping that the issue was resolved with UE 5.0.1 update, but it hasn’t.

@M0rph3u5_UK As a workaround you could temporary create a first person project in UE5 and create your materials there and - after its finished - migrate it to your VR project. Not ideal but like that you could continue to work in UE5.

1 Like

@maxbrown thanks for your reply, I already did that (with third person template) shortly after leaving my original comment in this thread and it did indeed work, and even after I added the VR template, I was able to create materials initially with no issues but after a while it started crashing again.

I will probably need to avoid using materials for now as I am trying to prototype a level utilising the new modelling toolkit and need to run it in VR periodically to adjust the scale.
Hope they will fix it soon.
Thanks