Unreal Engine 5.0 Released

The Launcher only lists 5.0.0 to install when adding a new version. Do I have to install this then update again to 5.0.1?

I can’t tell you how many times I accidentally hit clean or even rebuild (which is right next to build in Rider) was doing the same thing. Then had to wait 30mins to fix the engine and all the plugins. thanks for this fix!

1 Like

I still see them in mine and i just updated, i think you are right they must have unchecked that. they are present in mine.

1 Like

It only shows 5.0.0 but it shows as 5.0.1 after installed. i did not have to install 2 times.

1 Like

I did a clean re-install to 5.0.1 and it resolved the issue! All I did was hit update in the launcher, didn’t even have an opportunity to make changes to my config.

If it happens again, I’ll just try reinstalling the component :slight_smile:

Thank you!

1 Like

CitySample is broken in 5.0.1 (plugins)

“r.” means it’s a renderer flag, try adding that line to your DefaultEngine.ini (except use r.DontLimitOnBattery=1)

PS. For the uninitiated, most renderer flags can be set by default this way :writing_hand: :wink:

1 Like

When I try to use the Bulk Edit Via Property Matrix feature, the Bulk Edit tab opens (with a title like “3 SoundWave Objects - …”), but it’s just a blank tab with no properties for me to edit and no way to do anything. What do I have to do to make the Bulk Edit feature work? It worked fine until I moved my project to UE5.

Whoops, I think I just figured it out – I had to go under “Window” and enable “Property Editor.” Shouldn’t that be enabled by default?

Thanks for the hotfix, there are still some important (to me) issues:
-In editor, Add/Marketplace does nothing
-3DConnexion plugin does not work on any of my own project (cine/blank), works in city sample
-no way to abort long-time process like import
I have asked in Discord but no comments so I try now here :slight_smile:

Custom data on instances is still broken, dang :frowning:

Has anyone managed to get foliage to block the navmesh yet? I’ve tried many different setups (that all worked in 4.26) but no matter what I do, the navmesh just ignores foliage of any kind. The foliage still has collision (pawns cannot pass through) but AI just try to navigate through a tree trunk resulting in them getting stuck. :frowning:

The most annoying bug I found so far is the loss of precision of object transforms. Specifically, scale and rotate have now worse precision than when FTransfom was using floats. It makes my own origin shifting thing unusable because of considerable jitter between the cells.
I know its still early for UE5 but its kind of annoying that in practice LWC is making things worse than they were. :frowning:

This pops up on Save All. Feels like the entire project shaders are compiled after upgrading from 5.0.0 to 5.0.1.
shader_fun_with_ue5

Recommendation

  • Update the popup progression for shader compilation, in 5.0.2 with the current progress.
  • Add a feature to pause shader compilation.
  • Play a sound once shaders are compiled.

Using UE4 skeletons / animations
Bug: Retarget animation feature offers no target skeletons. Workaround: If the original skeleton has been removed, animations can be assigned to target skeleton.

exposure is broken in 5.0 and 5.0.1

Its not working

Screenshot_1


Hello. I know a lot of people are getting this error. Now I have an crash every 5 minutes. It’s getting incredibly frustrating. Any progress on this error? Because I am no longer able to use UE 5.
I am using Win 11.

I have exactly the same issue. An update appeared in the launcher to 5.0.1 and now all the templates are gone. I don’t see an option to wind this back etc.

What is the suggested fix please?

Never mind… I see the little drop down arrow next to the LAUNCH button where I could select options and then check templates and content again.

Currently, in 5.0.1, any static foliage meshes used in a Landscape Grass Type that also use Nanite will not spawn procedurally, regardless of material setup. A solution to this would be greatly appreciated!

(See this post for details: Landscape Grass - Nanite)

5.0.1 Bug: Video Media player not working properly
Fix: UE5 Video Media player not working properly - #27 by unit23