Download

Unreal Engine 4.24 Preview

@LeFxGuy the WASD hotkeys used in the sculpt tools have been changed in Preview 2 (sorry!)

@Megamaomao fantastic tutorial! One note: You don’t have to enable the Mesh Editor plugin. You only need to enable “Modeling Tools Editor Mode” and that will auto-enable other necessary plugins.

I noticed the stuff tracking the software cursor in 4.24 moved from slate application to the slate user, does this make it possible for splitscreen to have individual cursors now (for joystick mouse via FAnalogCursor)?

I am seeing excellent Raytracing gains in very reflection intensive areas. (Net gain upto 30%). Well done!

Not looking good. I am compiling. Here is a listing of the errors. I did just like 4.23.1.


Could you try it? Any advice?

I really do love the new project creation panel, but as we now have so many options available, can you add the option for using the Forward or Deferred Renderer? For someone often creating VR Projects that would come in handy. Nice work on the Update!

Hmm seems bad… Maybe it does not worth the time to mess with Chaos while still on preview…

Unfortunately I can’t invest time into this for now, since I am already in a project delay that I can’t afford increase any further. Sorry.

This is the same error that I got yesterday. I tried updating the chaos project, but it doesn’t look like any of the source files were updated. I’m trying the build again now anyways.

GTAO only renders in the left eye in VR, is that something that will be fixed?

Loving the new sun + sky setup and correct lighting levels as it will make it so much easier to light internals.

Is the lightmass build lighting currently disabled? Just trying a few separate projects, the build lighting doesn’t function.

Edit; Oops. When Raytrace is turned off with the archviz template, it looks like the new template still has “force no computed lighting” on.

Anybody, experts, how to activate this two modes? Plugins enabled but i cant find where is this modes in UE…
I know, its experimental but how to and where is that?

Let me know if you get to work. Thanks.

What I don’t understand is that Chaos is working in 4.23.1. How did you break it?

If you are looking for stability, you shouldn’t be updating to preview versions. Hell, you might want to skip hotfixes if everything works for you on your current version. Chaos is still in beta as well so expect things to be rocky until it’s out of experimental. You’re just going to have to be patient.

How about just don’t use the half-baked features until they’re fixed and optimized? By your logic, it’s the same as them not being there.

I see, I misunderstood your previous post. However, I’m still in the opinion that UE is still a relatively stable product and that bugs are addressed to a reasonable degree.

[USER=“254473”]Pirate Tony[/USER] open the Plugins dialog (Edit -> Plugins) and type “modeling tools editor mode” into the search box. Enable that plugin and restart the Editor.

Hi. I am having the same issues. All I did was download the zip from the 4.24 GitHub branch. Unblock, Unzip. Setup then generate. Upon compiling, it appears all the datasmith headers are missing or not found.

Anyone have a fix?

I was able to get Chaos demo to compile after updating the project, and the 4.24 engine source off github. However, the project doesn’t load. It’s creating zombie processes that won’t close in Task Manager.

I’m not sure what this is error about.
LogInit: Display: Running incorrect executable for target. Launching D:/Unreal Projects/4_24/ChaosDestruction424/Binaries/Win64/ChaosDestructionDemoEditor.exe…

I don’t think the datasmith errors are actually a problem. The engine still builds with those errors. I think they just mean you don’t have the 3rd party libraries needed to compile those for datasmith. I had those errors and was still able to create a new project, or open an old project. I’m just having trouble with the Chaos Demo.

Here are the errors. 18 I think.

Chaos works OK for me in 4.23.1. Epic doesn’t seem to be interested in fixing it.