Unreal Engine 4.24 Preview

Don’t get me wrong, but your comment about Epic is not true. This is a “preview” for 4.24, it is not a “release”, so you need to understand that it is completely possible for it to contain errors as it is under active development, meaning it is not ready. The previews are intended for people to see the new content and also fixes from previous release that “might” be in the build. All I can say is that it is not intended for all audiences when it comes to features like Chaos, which needs build from source and not all users can do it right or have the time to spent compiling all the code which takes considerable time and will increase as more things are added into the engine year by year. You can use the Chaos with UE4.23, this one is ok since it is a release already and wait for UE4.24 to come out of preview to try again, since I don’t think worth the trouble as it is, but it is good to know the capabilities, since if you start a project using it, it is sure changes might break things, so better wait for it to come out of beta.

No problem. Chaos is a great addition for unreal I would like to a jump with it. Thanks.

Can’t get any projects to compile in 4.24 at all.

If I switch to the “legacy” build settings, I get build log spam of this:

cl : Command line error D8049: cannot execute 'C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.16.27023\bin\HostX64\x64\c1xx.dll': command line is too long to fit in debug record

If I adopt the “new” system, I get build log spam of not being able to find any of my headers - in a project with >1,000 files this is a real nightmare if I have to go through and manually edit ALL the include paths.

Why on earth was this changed deemed a good idea?

EDIT: Bit the bullet and updated all my include paths in the project. Nightmare fuel.

Can you build the Aja and Blackmagic plugins for 4.24? Really wanted to try the virtual production template and give feedback but without these plugins you can’t try all the functions.

How to make a Hair Alembic File?

When I use the new Alembic curves to create hair, there will be problems replacing the shader. The first shader to be replaced must be named the same as the previous one, and it cannot use the instance shader

Now I can only modify base color

Just downloaded the source for 4.24 P2. 18 errors the last time I tried. Has anyone tried? Interesting. Epic are you getting into the bedsheets business. ha!

I just copied my VR project to the new 4.24 and i see that’s haven’t motion controller float Axis value.

Where are they? I hope you will add that, like on previous all versions, or please answer how can i get that pure float values. Thanks

There are more posts like this here nowadays, @VictorLerp weren’t the first post of each user authorized by a moderator before? That’s how I remember at least.
Alternatively, we could have a simple Report button to report spams.

The generic motion controller keys are disabled now and you need to get it per-device. Previously that thumbstick value would have had 3 or 4 different meanings depending on which vr plugin you were using (it could have been a touchpad on a WMR controller that also had a thumbstick, etc.).

@VictorLerp This portion of the forums does not show the report button (to use in case of spam), at least not for me.

@VictorLerp @NilsonLima

Official Epic threads don’t offer a flag link (not just previews).
Some of us have been WARNING Epic about this for years.
Interesting how even ‘Community Managers’ don’t know this.
I guess there’s not much Fortnite money for the UE4 forums.:frowning:…58/unknown.png

Fix Please!

Does landscape sculpture take place through a processor or video card? If through the processor. I would like what was through the video card. It would not be bad for the landscape tools to work just as fast.

Yep, that’s what I was referring to. Thanks for linking it. There’s comments from people saying that they’ve tried it and it works now. Hopefully Epic can validate it for Preview 3 so that we can compile projects again while being on the latest VS 2019 version.

I’m curious what you refer to, because I am testing 4.24 with VS2019 and everything here is compiling completely fine.

So I been playing with the mesh editing tools and i turned on the inspector and i check marked this box “boundry edges” and it is showing red lines in my mesh
the red lines just so happen to be where i’m seeing some really badly shaded areas on the model.

My question what exactly does this mean “open boundry edges” and why are they causing my lighting to look horrible?

i don’t see any errors in blender on my model but once in ue4 it shows these errors? how do i fix this issue?

or a better question how can i “close” these boundary edges so they stop messing up my lighting?

good job!where could i download it?

I compiled 4.24 p2 with vs2017. 18 errors. Using vs2019 with no errors??? And Chaos worked.

This is still a dealbreaker with Arch viz…even on a small revit model, often we get so many pieces in.
This leads to insane build times on even preview mode with light-mapping


Really hoping a gpu solution can be looked at in 2020