Unreal 5 Lumen imported models have no Surface Cache

Hi, I imported many models, and non of them have Surface Cache required for Lumen. I can see in Lumen preview windows that everything, except objects that are created in the engine itself are black.

How do I solve this issue?

Most likely cause is that you didn’t set them to generate mesh distance fields or the mesh distance field resolution scale is set to 0. (Not sure why but this appears to be the default in my project and it screws me up every single time I import a mesh). Set the resolution scale to a non-0 value and it should work

Thanks. Generate mesh distance field was set to false on all my meshes. However, that did nothing.

I enabled Nanite and that seems to fixed the problem.

However, I see no performance boost, so what is the point of Nanite then?
Edit: Never mind, I see that the majority of my meshes are black in Nanite preview - not “Nanitable” for some reason.