[Unreal 5.1.0] Seam in the Ocean?

Can anyone help me with this problem? There is always a seam between the landscape the ocean.

So I created a landscape using the default value it provides

Then dragged Water Body Ocean onto it

And booya there’s this weird portion of water in the volume floating in the air. Does anyone know how to fix this? I believe this was not a thing in UE 5.0

Hey there @RoyalKirin! Welcome to the community! After a certain distance from the center, the water body actually turns into a lower resolution/imposter of itself for performance purposes, so you usually do see there the seams in editor, but if your gameplay is confined to the island it’s usually quite hard to pick out!

However the artifacting where the chunks of land are still poking through near the edges is a bit of a problem. This generally occurs if the water volume itself doesn’t cover the entirety of the landmass, or if the curve itself is adjusted too close or too far.

1 Like

One way that I found to kind of band-aid fix this is to just increase the landscape size, then apply the Ocean actor to it.

2 Likes

Hey there @RoyalKirin !
Yesterday I’ve come up with this same issue and din’t know at all how to get rid of that seam.

Today I discovered (sincerely don’t know why, but it seems to be working) that selecting ‘WaterBodyOcean’ and scrolling down to ‘Wave’, go on ‘Waves Source’.

Right there I got ‘Water Waves Asset Reference’ or something similar selected. If you click on the dropdown and switch to another option, then back to ‘Water Waves…etc’ you’ll notice that the seam disappears and the water level on your landscape is now the same as the rest of the ocean.

Hope this works for you!